Data exposure via ZeroMQ on multi-node vLLM deployment
CVE-2025-30202GHSA-9f8f-2vmf-885j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.8.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vllm
- Affected
- >= 0.5.2, < 0.8.5
- Fixed in
- 0.8.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9f8f-2vmf-885j lists affected ranges: PyPI vllm >=0.5.2 <0.8.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9f8f-2vmf-885j lists affected ranges: PyPI vllm >=0.5.2 <0.8.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2025-30202: 0.61% estimated exploitation activity in the next 30 days; percentile 49.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact In a multi-node vLLM deployment, vLLM uses ZeroMQ for some multi-node communication purposes. The primary vLLM host opens an XPUB ZeroMQ socket and binds it to ALL interfaces. While the socket is always opened for a multi-node deployment, it is only used when doing tensor parallelism across multiple hosts. Any client with network access to this host can connect to this XPUB socket unless its port is blocked by a firewall. Once connected, these arbitrary clients will receive all of the same data broadcasted to all of the secondary vLLM hosts. This data is internal vLLM state information that is not useful to an attacker. By potentially connecting to this socket many times and not reading data published to them, an attacker can also cause a denial of service by slowing down or potentially blocking the publisher. Detailed Analysis The XPUB socket in question is created here:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9f8f-2vmf-885j
- Revision 1 · created ·
Published from osv record GHSA-9f8f-2vmf-885j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-30202 Advisory: Data exposure via ZeroMQ on multi-node vLLM deployment IDs: CVE-2025-30202, GHSA-9f8f-2vmf-885j Record: https://patchnext.com/advisories/cve-2025-30202 (revision 2, source checked 26 Oct 2026, 13:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vllm 0.8.5. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vllm: affected >= 0.5.2, < 0.8.5; fixed in 0.8.5 ## Suggested inspection (read-only) - `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vllm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9f8f-2vmf-885j (OSV record GHSA-9f8f-2vmf-885j lists affected ranges: PyPI vllm >=0.5.2 <0.8.5 (fixed)) - Verified: https://github.com/advisories/GHSA-9f8f-2vmf-885j (GitHub-reviewed advisory GHSA-9f8f-2vmf-885j lists affected ranges: PyPI vllm >=0.5.2 <0.8.5) Commands are suggestions: review each one before running it.
Loading voting…