Skip to content

← Actionable
Medium, CVSS 6.9amended

Parse Server has an OAuth login vulnerability

CVE-2025-30168GHSA-837q-jhwx-cmpv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 8.0.2, 7.5.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm parse-server

    Affected
    < 7.5.2>= 8.0.0, < 8.0.2
    Fixed in
    8.0.2, 7.5.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:N
EPSS
  • CVE-2025-30168: 0.41% estimated exploitation activity in the next 30 days; percentile 34.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The 3rd party authentication handling of Parse Server allows the authentication credentials of some specific authentication providers to be used across multiple Parse Server apps. For example, if a user signed up using the same authentication provider in two unrelated Parse Server apps, the credentials stored by one app can be used to authenticate the same user in the other app. Note that this only affects Parse Server apps that specifically use an affected 3rd party authentication provider for user authentication, for example by setting the Parse Server option auth to configure a Parse Server authentication adapter. See the 3rd party authentication docs for more information on which authentication providers are affected. Patches The fix of this vulnerability requires to upgrade Parse Server to a version that includes the bug fix, as well as upgrade the client app to send a secure payload, which is different from the previous insecure payload. To accommodate a gradual rollout…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-837q-jhwx-cmpv

  2. Revision 1 · created ·

    Published from osv record GHSA-837q-jhwx-cmpv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-30168

Advisory: Parse Server has an OAuth login vulnerability
IDs: CVE-2025-30168, GHSA-837q-jhwx-cmpv
Record: https://patchnext.com/advisories/cve-2025-30168 (revision 2, source checked 26 Oct 2026, 12:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse-server 8.0.2, 7.5.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse-server: affected < 7.5.2; >= 8.0.0, < 8.0.2; fixed in 8.0.2, 7.5.2

## Suggested inspection (read-only)
- `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-837q-jhwx-cmpv (OSV record GHSA-837q-jhwx-cmpv lists affected ranges: npm parse-server >=0 =8.0.0 <8.0.2 (fixed))
- Verified: https://github.com/advisories/GHSA-837q-jhwx-cmpv (GitHub-reviewed advisory GHSA-837q-jhwx-cmpv lists affected ranges: npm parse-server >=0 =8.0.0 <8.0.2)

Commands are suggestions: review each one before running it.

Loading voting…