Pimcore's Admin Classic Bundle allows HTML Injection
CVE-2025-30166GHSA-x82r-6j37-vrgg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pimcore/admin-ui-classic-bundle 1.7.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist pimcore/admin-ui-classic-bundle
- Affected
- < 1.7.6
- Fixed in
- 1.7.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x82r-6j37-vrgg lists affected ranges: Packagist pimcore/admin-ui-classic-bundle >=0 <1.7.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 1.8 · CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:A/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-30166: 0.26% estimated exploitation activity in the next 30 days; percentile 17.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An HTML injection issue allows users with access to the email sending functionality to inject arbitrary HTML code into emails sent via the admin interface, potentially leading to session cookie theft and the alteration of page content. Details The vulnerability was discovered in the /admin/email/send-test-email endpoint using the POST method. The vulnerable parameter is content, which permits the injection of arbitrary HTML code during the email sending process. While JavaScript code injection is blocked through filtering, HTML code injection remains possible. PoC To reproduce the vulnerability, a user must fill out the email's content form with the desired HTML payload. Impact This HTML injection vulnerability can potentially enable phishing attacks by allowing the insertion of any html like fake login forms, etc. All functionalities that process user input should be carefully reviewed to ensure that data is appropriately encoded as HTML entities in server responses. For…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-x82r-6j37-vrgg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-30166 Advisory: Pimcore's Admin Classic Bundle allows HTML Injection IDs: CVE-2025-30166, GHSA-x82r-6j37-vrgg Record: https://patchnext.com/advisories/cve-2025-30166 (revision 1, source checked 26 Oct 2026, 14:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 1.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pimcore/admin-ui-classic-bundle 1.7.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist pimcore/admin-ui-classic-bundle: affected < 1.7.6; fixed in 1.7.6 ## Suggested inspection (read-only) - Packagist pimcore/admin-ui-classic-bundle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pimcore/admin-ui-classic-bundle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x82r-6j37-vrgg (GitHub-reviewed advisory GHSA-x82r-6j37-vrgg lists affected ranges: Packagist pimcore/admin-ui-classic-bundle >=0 <1.7.6) Commands are suggestions: review each one before running it.
Loading voting…