Remote Code Execution Vulnerability in vLLM Multi-Node Cluster Configuration
CVE-2025-30165GHSA-9pcc-gvx5-r5wm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.10.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vllm
- Affected
- >= 0.5.2, < 0.10.0
- Fixed in
- 0.10.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9pcc-gvx5-r5wm lists affected ranges: PyPI vllm >=0.5.2 <0.10.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9pcc-gvx5-r5wm lists affected ranges: PyPI vllm >=0.5.2 <0.10.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.0 · CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-30165: 0.56% estimated exploitation activity in the next 30 days; percentile 46.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected Environments Note that this issue only affects the V0 engine, which has been off by default since v0.8.0. Further, the issue only applies to a deployment using tensor parallelism across multiple hosts, which we do not expect to be a common deployment pattern. Since V0 is has been off by default since v0.8.0 and the fix is fairly invasive, we have decided not to fix this issue. Instead we recommend that users ensure their environment is on a secure network in case this pattern is in use. The V1 engine is not affected by this issue. Impact In a multi-node vLLM deployment using the V0 engine, vLLM uses ZeroMQ for some multi-node communication purposes. The secondary vLLM hosts open a SUB ZeroMQ socket and connect to an XPUB socket on the primary vLLM host. https://github.com/vllm-project/vllm/blob/c21b99b91241409c2fdf9f3f8c542e8748b317be/vllm/distributed/devicecommunicators/shmbroadcast.py#L295-L301 When data is received on this SUB socket, it is deserialized with pickle. This…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9pcc-gvx5-r5wm
- Revision 1 · created ·
Published from osv record GHSA-9pcc-gvx5-r5wm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-30165 Advisory: Remote Code Execution Vulnerability in vLLM Multi-Node Cluster Configuration IDs: CVE-2025-30165, GHSA-9pcc-gvx5-r5wm Record: https://patchnext.com/advisories/cve-2025-30165 (revision 2, source checked 26 Oct 2026, 13:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vllm 0.10.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vllm: affected >= 0.5.2, < 0.10.0; fixed in 0.10.0 ## Suggested inspection (read-only) - `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vllm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9pcc-gvx5-r5wm (OSV record GHSA-9pcc-gvx5-r5wm lists affected ranges: PyPI vllm >=0.5.2 <0.10.0 (fixed)) - Verified: https://github.com/advisories/GHSA-9pcc-gvx5-r5wm (GitHub-reviewed advisory GHSA-9pcc-gvx5-r5wm lists affected ranges: PyPI vllm >=0.5.2 <0.10.0) Commands are suggestions: review each one before running it.
Loading voting…