Skip to content

← Actionable
Low, CVSS 3.2

Cilium East-west traffic not subject to egress policy enforcement for requests via Gateway API load balancers

CVE-2025-30162GHSA-24qp-4xx8-3jvj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/cilium/cilium 1.17.2, 1.16.8, 1.15.15), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/cilium/cilium

    Affected
    >= 1.16.0, < 1.16.8>= 1.17.0, < 1.17.2>= 1.15.0, < 1.15.15
    Fixed in
    1.16.8, 1.15.15, 1.17.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.2 · CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:L/I:N/A:N
EPSS
  • CVE-2025-30162: 0.22% estimated exploitation activity in the next 30 days; percentile 13.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact For Cilium users who: - Use Gateway API for Ingress for some services AND - Use LB-IPAM or BGP for LB Service implementation AND - Use network policies to block egress traffic from workloads in a namespace to workloads in other namespaces Egress traffic from workloads covered by such network policies to LoadBalancers configured by Gateway resources will incorrectly be allowed. LoadBalancer resources not deployed via a Gateway API configuration are not affected by this issue. Patches This issue was fixed by https://github.com/cilium/proxy/pull/1172. This issue affects: - Cilium v1.15 between v1.15.0 and v1.15.14 inclusive - Cilium v1.16 between v1.16.0 and v1.16.7 inclusive - Cilium v1.17 between v1.17.0 and v1.17.1 inclusive This issue is fixed in: - Cilium v1.15.15 - Cilium v1.16.8 - Cilium v1.17.2 Workarounds A Clusterwide Cilium Network Policy can be used to work around this issue for users who are unable to upgrade. An outline of such a policy is provided below: - The…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-24qp-4xx8-3jvj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-30162

Advisory: Cilium East-west traffic not subject to egress policy enforcement for requests via Gateway API load balancers
IDs: CVE-2025-30162, GHSA-24qp-4xx8-3jvj
Record: https://patchnext.com/advisories/cve-2025-30162 (revision 1, source checked 26 Oct 2026, 15:09 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/cilium/cilium 1.17.2, 1.16.8, 1.15.15. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/cilium/cilium: affected >= 1.16.0, < 1.16.8; >= 1.17.0, < 1.17.2; >= 1.15.0, < 1.15.15; fixed in 1.16.8, 1.15.15, 1.17.2

## Suggested inspection (read-only)
- Go github.com/cilium/cilium: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/cilium/cilium.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-24qp-4xx8-3jvj (GitHub-reviewed advisory GHSA-24qp-4xx8-3jvj lists affected ranges: Go github.com/cilium/cilium >=1.16.0 =1.17.0 =1.15.0 <1.15.15)

Commands are suggestions: review each one before running it.

Loading voting…