Skip to content

← Actionable
High, CVSS 7.5

Improper Handling of Highly Compressed Data (Data Amplification) in github.com/getkin/kin-openapi/openapi3filter

CVE-2025-30153GHSA-wq9g-9vfc-cfq9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/getkin/kin-openapi 0.131.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2025-30153: 0.62% estimated exploitation activity in the next 30 days; percentile 49.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When validating a request with a multipart/form-data schema, if the OpenAPI schema allows it, an attacker can upload a crafted ZIP file (e.g., a ZIP bomb), causing the server to consume all available system memory. Details The root cause comes from the ZipFileBodyDecoder, which is registered automatically by the module (contrary to what the documentation says. PoC To reproduce the vulnerability, you can use the following OpenAPI schema: And this code to validate the request (nothing fancy, it basically only calls the openapi3filter.ValidateRequest function): We also need to create a zip bomb. This command will create a 4.7GB file and compress it to to 4.7MB zip archive: Run the PoC provided, and upload the zip bomb with curl localhost:8080/ -F file="@/tmp/bomb.zip;type=application/zip" -v. Observe the memory consumption of the test server during and after the upload (it jumped to a bit over 22GB in my testing, with only a 4.7MB input file, you can reduce the size of the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wq9g-9vfc-cfq9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-30153

Advisory: Improper Handling of Highly Compressed Data (Data Amplification) in github.com/getkin/kin-openapi/openapi3filter
IDs: CVE-2025-30153, GHSA-wq9g-9vfc-cfq9
Record: https://patchnext.com/advisories/cve-2025-30153 (revision 1, source checked 26 Oct 2026, 15:09 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/getkin/kin-openapi 0.131.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/getkin/kin-openapi: affected < 0.131.0; fixed in 0.131.0

## Suggested inspection (read-only)
- Go github.com/getkin/kin-openapi: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/getkin/kin-openapi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wq9g-9vfc-cfq9 (GitHub-reviewed advisory GHSA-wq9g-9vfc-cfq9 lists affected ranges: Go github.com/getkin/kin-openapi >=0 <0.131.0)

Commands are suggestions: review each one before running it.

Loading voting…