Skip to content

← Actionable
Medium, CVSS 6.5

Sylius PayPal Plugin has an Order Manipulation Vulnerability after PayPal Checkout

CVE-2025-30152GHSA-hxg4-65p5-9w37

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sylius/paypal-plugin 2.0.2, 1.7.2, 1.6.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist sylius/paypal-plugin

    Affected
    < 1.6.2>= 1.7.0, < 1.7.2>= 2.0.0, < 2.0.2
    Fixed in
    1.7.2, 2.0.2, 1.6.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
EPSS
  • CVE-2025-30152: 0.35% estimated exploitation activity in the next 30 days; percentile 28.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A discovered vulnerability allows users to modify their shopping cart after completing the PayPal Checkout process and payment authorization. If a user initiates a PayPal transaction from a product page or the cart page and then returns to the order summary page, they can still manipulate the cart contents before finalizing the order. As a result, the order amount in Sylius may be higher than the amount actually captured by PayPal, leading to a scenario where merchants deliver products or services without full payment. Impact - Users can exploit this flaw to receive products/services without paying the full amount. - Merchants may suffer financial losses due to underpaid orders. - Trust in the integrity of the payment process is compromised. Patches The issue is fixed in versions: 1.6.2, 1.7.2, 2.0.2 and above. Workarounds To resolve the problem in the end application without updating to the newest patches, there is a need to overwrite PayPalOrderCompleteProcessor with modified…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hxg4-65p5-9w37

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-30152

Advisory: Sylius PayPal Plugin has an Order Manipulation Vulnerability after PayPal Checkout
IDs: CVE-2025-30152, GHSA-hxg4-65p5-9w37
Record: https://patchnext.com/advisories/cve-2025-30152 (revision 1, source checked 26 Oct 2026, 14:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sylius/paypal-plugin 2.0.2, 1.7.2, 1.6.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist sylius/paypal-plugin: affected < 1.6.2; >= 1.7.0, < 1.7.2; >= 2.0.0, < 2.0.2; fixed in 1.7.2, 2.0.2, 1.6.2

## Suggested inspection (read-only)
- Packagist sylius/paypal-plugin: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sylius/paypal-plugin.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hxg4-65p5-9w37 (GitHub-reviewed advisory GHSA-hxg4-65p5-9w37 lists affected ranges: Packagist sylius/paypal-plugin >=0 =1.7.0 =2.0.0 <2.0.2)

Commands are suggestions: review each one before running it.

Loading voting…