Shopware allows Denial Of Service via password length
CVE-2025-30151GHSA-cgfj-hj93-rmh2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (shopware/core 6.7.0.0-rc2, 6.6.10.3, 6.5.8.17; shopware/platform 6.7.0.0-rc2, 6.6.10.3, 6.5.8.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist shopware/core
- Affected
- >= 6.6.0.0, < 6.6.10.3>= 6.7.0.0-rc1, < 6.7.0.0-rc2< 6.5.8.17
- Fixed in
- 6.6.10.3, 6.5.8.17, 6.7.0.0-rc2
Packagist shopware/platform
- Affected
- >= 6.6.0.0, < 6.6.10.3>= 6.7.0.0-rc1, < 6.7.0.0-rc2< 6.5.8.17
- Fixed in
- 6.6.10.3, 6.5.8.17, 6.7.0.0-rc2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cgfj-hj93-rmh2 lists affected ranges: Packagist shopware/core >=6.6.0.0 =6.7.0.0-rc1 =0 =6.6.0.0 =6.7.0.0-rc1 =0 <6.5.8.17
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2025-30151: 0.43% estimated exploitation activity in the next 30 days; percentile 36.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact It's possible to pass long passwords that leads to Denial Of Service via forms in Storefront forms or Store-API. Patches Update to Shopware 6.6.10.3 or 6.5.8.17 Workarounds For older versions of 6.4, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-cgfj-hj93-rmh2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-30151 Advisory: Shopware allows Denial Of Service via password length IDs: CVE-2025-30151, GHSA-cgfj-hj93-rmh2 Record: https://patchnext.com/advisories/cve-2025-30151 (revision 1, source checked 26 Oct 2026, 14:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: shopware/core 6.7.0.0-rc2, 6.6.10.3, 6.5.8.17; shopware/platform 6.7.0.0-rc2, 6.6.10.3, 6.5.8.17. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist shopware/core: affected >= 6.6.0.0, < 6.6.10.3; >= 6.7.0.0-rc1, < 6.7.0.0-rc2; < 6.5.8.17; fixed in 6.6.10.3, 6.5.8.17, 6.7.0.0-rc2 - Packagist shopware/platform: affected >= 6.6.0.0, < 6.6.10.3; >= 6.7.0.0-rc1, < 6.7.0.0-rc2; < 6.5.8.17; fixed in 6.6.10.3, 6.5.8.17, 6.7.0.0-rc2 ## Suggested inspection (read-only) - Packagist shopware/core: check the installed version with your package manager. - Packagist shopware/platform: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on shopware/core, shopware/platform. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cgfj-hj93-rmh2 (GitHub-reviewed advisory GHSA-cgfj-hj93-rmh2 lists affected ranges: Packagist shopware/core >=6.6.0.0 =6.7.0.0-rc1 =0 =6.6.0.0 =6.7.0.0-rc1 =0 <6.5.8.17) Commands are suggestions: review each one before running it.
Loading voting…