Fast-JWT Improperly Validates iss Claims
CVE-2025-30144GHSA-gm45-q3v2-6cf8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fast-jwt 5.0.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm fast-jwt
- Affected
- < 5.0.6
- Fixed in
- 5.0.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gm45-q3v2-6cf8 lists affected ranges: npm fast-jwt >=0 <5.0.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gm45-q3v2-6cf8 lists affected ranges: npm fast-jwt >=0 <5.0.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:N
- EPSS
- CVE-2025-30144: 0.59% estimated exploitation activity in the next 30 days; percentile 48.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The fast-jwt library does not properly validate the iss claim based on the RFC https://datatracker.ietf.org/doc/html/rfc7519#page-9. Details The iss (issuer) claim validation within the fast-jwt library permits an array of strings as a valid iss value. This design flaw enables a potential attack where a malicious actor crafts a JWT with an iss claim structured as ['https://attacker-domain/', 'https://valid-iss']. Due to the permissive validation, the JWT will be deemed valid. Furthermore, if the application relies on external libraries like get-jwks that do not independently validate the iss claim, the attacker can leverage this vulnerability to forge a JWT that will be accepted by the victim application. Essentially, the attacker can insert their own domain into the iss array, alongside the legitimate issuer, and bypass the intended security checks. PoC Take a server running the following code: Now we build a server that will be used to generate the JWT token and send the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-gm45-q3v2-6cf8
- Revision 1 · created ·
Published from osv record GHSA-gm45-q3v2-6cf8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-30144 Advisory: Fast-JWT Improperly Validates iss Claims IDs: CVE-2025-30144, GHSA-gm45-q3v2-6cf8 Record: https://patchnext.com/advisories/cve-2025-30144 (revision 2, source checked 26 Oct 2026, 12:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fast-jwt 5.0.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm fast-jwt: affected < 5.0.6; fixed in 5.0.6 ## Suggested inspection (read-only) - `npm ls fast-jwt --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fast-jwt. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-gm45-q3v2-6cf8 (OSV record GHSA-gm45-q3v2-6cf8 lists affected ranges: npm fast-jwt >=0 <5.0.6 (fixed)) - Verified: https://github.com/advisories/GHSA-gm45-q3v2-6cf8 (GitHub-reviewed advisory GHSA-gm45-q3v2-6cf8 lists affected ranges: npm fast-jwt >=0 <5.0.6) Commands are suggestions: review each one before running it.
Loading voting…