Apache ActiveMQ NMS OpenWire Client Deserialization of Untrusted Data vulnerability
CVE-2025-29953GHSA-9g64-r942-fvmp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache.nms.activemq 2.1.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet apache.nms.activemq
- Affected
- < 2.1.1
- Fixed in
- 2.1.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9g64-r942-fvmp lists affected ranges: NuGet apache.nms.activemq >=0 <2.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-29953: 2.09% estimated exploitation activity in the next 30 days; percentile 81.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Deserialization of Untrusted Data vulnerability in Apache ActiveMQ NMS OpenWire Client. This issue affects Apache ActiveMQ NMS OpenWire Client before 2.1.1 when performing connections to untrusted servers. Such servers could abuse the unbounded deserialization in the client to provide malicious responses that may eventually cause arbitrary code execution on the client. Version 2.1.0 introduced a allow/denylist feature to restrict deserialization, but this feature could be bypassed. The .NET team has deprecated the built-in .NET binary serialization feature starting with .NET 9 and suggests migrating away from binary serialization. The project is considering to follow suit and drop this part of the NMS API altogether. Users are recommended to upgrade to version 2.1.1, which fixes the issue. We also recommend to migrate away from relying on .NET binary serialization as a hardening method for the future.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9g64-r942-fvmp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-29953 Advisory: Apache ActiveMQ NMS OpenWire Client Deserialization of Untrusted Data vulnerability IDs: CVE-2025-29953, GHSA-9g64-r942-fvmp Record: https://patchnext.com/advisories/cve-2025-29953 (revision 1, source checked 26 Oct 2026, 17:03 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache.nms.activemq 2.1.1. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet apache.nms.activemq: affected < 2.1.1; fixed in 2.1.1 ## Suggested inspection (read-only) - NuGet apache.nms.activemq: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache.nms.activemq. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9g64-r942-fvmp (GitHub-reviewed advisory GHSA-9g64-r942-fvmp lists affected ranges: NuGet apache.nms.activemq >=0 <2.1.1) Commands are suggestions: review each one before running it.
Loading voting…