Skip to content

← Actionable
High, CVSS 7.9

The WikiManager REST API allows any user to create wikis

CVE-2025-29926GHSA-gfp2-6qhm-7x43

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-wiki-rest-default 16.10.0, 16.4.6, 15.10.15), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-gfp2-6qhm-7x43 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-wiki-rest-default >=5.4-rc-1 =16.0.0-rc-1 =16.5.0-rc-1 <16.10.0

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2025-29926: 0.58% estimated exploitation activity in the next 30 days; percentile 47.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Any user can exploit the WikiManager REST API to create a new wiki, where the user could become an administrator and so performs other attacks on the farm. Note that this REST API is not bundled in XWiki Standard by default: it needs to be installed manually through the extension manager. Patches The problem has been patched in versions 15.10.15, 16.4.6 and 16.10.0 of the REST module. Workarounds There's no workaround other than upgrading the dependency. References JIRA ticket: https://jira.xwiki.org/browse/XWIKI-22490 Commit of the fix: https://github.com/xwiki/xwiki-platform/commit/82aa670106c7f5e6238ca6ed59a52d1800e05b99 For more information If you have any questions or comments about this advisory: Open an issue in Jira XWiki.org Email us at Security Mailing List Attribution You can specify here who reported the issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gfp2-6qhm-7x43

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-29926

Advisory: The WikiManager REST API allows any user to create wikis
IDs: CVE-2025-29926, GHSA-gfp2-6qhm-7x43
Record: https://patchnext.com/advisories/cve-2025-29926 (revision 1, source checked 26 Oct 2026, 16:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-wiki-rest-default 16.10.0, 16.4.6, 15.10.15. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.xwiki.platform:xwiki-platform-wiki-rest-default: affected >= 5.4-rc-1, < 15.10.15; >= 16.0.0-rc-1, < 16.4.6; >= 16.5.0-rc-1, < 16.10.0; fixed in 16.10.0, 15.10.15, 16.4.6

## Suggested inspection (read-only)
- Maven org.xwiki.platform:xwiki-platform-wiki-rest-default: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.xwiki.platform:xwiki-platform-wiki-rest-default.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gfp2-6qhm-7x43 (GitHub-reviewed advisory GHSA-gfp2-6qhm-7x43 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-wiki-rest-default >=5.4-rc-1 =16.0.0-rc-1 =16.5.0-rc-1 <16.10.0)

Commands are suggestions: review each one before running it.

Loading voting…