Apache Linkis: Arbitrary File Read via Double URL Encoding Bypass
CVE-2025-29847GHSA-c399-q49h-qwc8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.linkis:linkis 1.8.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.linkis:linkis
- Affected
- >= 1.3.0, < 1.8.0
- Fixed in
- 1.8.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c399-q49h-qwc8 lists affected ranges: Maven org.apache.linkis:linkis >=1.3.0 <1.8.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2025-29847: 0.87% estimated exploitation activity in the next 30 days; percentile 58.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability in Apache Linkis. Problem Description When using the JDBC engine and data source functionality, if the URL parameter configured on the frontend has undergone multiple rounds of URL encoding, it may bypass the system's checks. This bypass can trigger a vulnerability that allows unauthorized access to system files via JDBC parameters. Scope of Impact This issue affects Apache Linkis: from 1.3.0 through 1.7.0. Severity level moderate Solution Continuously check if the connection information contains the "%" character; if it does, perform URL decoding. Users are recommended to upgrade to version 1.8.0, which fixes the issue. More questions about this vulnerability can be discussed here: https://lists.apache.org/list?dev@linkis.apache.org:2025-9:cve
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-c399-q49h-qwc8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-29847 Advisory: Apache Linkis: Arbitrary File Read via Double URL Encoding Bypass IDs: CVE-2025-29847, GHSA-c399-q49h-qwc8 Record: https://patchnext.com/advisories/cve-2025-29847 (revision 1, source checked 26 Oct 2026, 16:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.linkis:linkis 1.8.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.linkis:linkis: affected >= 1.3.0, < 1.8.0; fixed in 1.8.0 ## Suggested inspection (read-only) - Maven org.apache.linkis:linkis: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.linkis:linkis. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c399-q49h-qwc8 (GitHub-reviewed advisory GHSA-c399-q49h-qwc8 lists affected ranges: Maven org.apache.linkis:linkis >=1.3.0 <1.8.0) Commands are suggestions: review each one before running it.
Loading voting…