Sylius PayPal Plugin Payment Amount Manipulation Vulnerability
CVE-2025-29788GHSA-pqq3-q84h-pj6x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sylius/paypal-plugin 2.0.1, 1.7.1, 1.6.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist sylius/paypal-plugin
- Affected
- < 1.6.1>= 1.7.0, < 1.7.1>= 2.0.0, < 2.0.1
- Fixed in
- 2.0.1, 1.6.1, 1.7.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pqq3-q84h-pj6x lists affected ranges: Packagist sylius/paypal-plugin >=0 =1.7.0 =2.0.0 <2.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
- EPSS
- CVE-2025-29788: 0.50% estimated exploitation activity in the next 30 days; percentile 43.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability allows users to manipulate the final payment amount processed by PayPal. If a user modifies the item quantity in their shopping cart after initiating the PayPal Checkout process, PayPal will not receive the updated total amount. As a result, PayPal captures only the initially transmitted amount, while Sylius incorrectly considers the order fully paid based on the modified total. This flaw can be exploited both accidentally and intentionally, potentially enabling fraud by allowing customers to pay less than the actual order value. Impact - Attackers can intentionally pay less than the actual total order amount. - Business owners may suffer financial losses due to underpaid orders. - Integrity of payment processing is compromised. Patches The issue is fixed in versions: 1.6.1, 1.7.1, 2.0.1 and above. Workarounds To resolve the problem in the end application without updating to the newest patches, there is a need to overwrite ProcessPayPalOrderAction with modified logic:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-pqq3-q84h-pj6x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-29788 Advisory: Sylius PayPal Plugin Payment Amount Manipulation Vulnerability IDs: CVE-2025-29788, GHSA-pqq3-q84h-pj6x Record: https://patchnext.com/advisories/cve-2025-29788 (revision 1, source checked 26 Oct 2026, 14:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sylius/paypal-plugin 2.0.1, 1.7.1, 1.6.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist sylius/paypal-plugin: affected < 1.6.1; >= 1.7.0, < 1.7.1; >= 2.0.0, < 2.0.1; fixed in 2.0.1, 1.6.1, 1.7.1 ## Suggested inspection (read-only) - Packagist sylius/paypal-plugin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sylius/paypal-plugin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-pqq3-q84h-pj6x (GitHub-reviewed advisory GHSA-pqq3-q84h-pj6x lists affected ranges: Packagist sylius/paypal-plugin >=0 =1.7.0 =2.0.0 <2.0.1) Commands are suggestions: review each one before running it.
Loading voting…