In Azle, calling setTimer causes infinite loop of timers
CVE-2025-29776GHSA-xc76-5pf9-mx8m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (azle 0.30.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm azle
- Affected
- >= 0.27.0, < 0.30.0
- Fixed in
- 0.30.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xc76-5pf9-mx8m lists affected ranges: npm azle >=0.27.0 <0.30.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xc76-5pf9-mx8m lists affected ranges: npm azle >=0.27.0 <0.30.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:L · score source
- EPSS
- CVE-2025-29776: 0.38% estimated exploitation activity in the next 30 days; percentile 31.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Calling setTimer in Azle versions 0.27.0, 0.28.0, and 0.29.0 causes an immediate infinite loop of timers to be executed on the canister, each timer attempting to clean up the global state of the previous timer. The infinite loop will occur with any valid invocation of setTimer. Patches The problem has been fixed as of Azle version 0.30.0. Workarounds If a canister is caught in this infinite loop after calling setTimer, the canister can be upgraded and the timers will all be cleared, thus ending the loop.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-xc76-5pf9-mx8m
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-xc76-5pf9-mx8m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-29776 Advisory: In Azle, calling `setTimer` causes infinite loop of timers IDs: CVE-2025-29776, GHSA-xc76-5pf9-mx8m Record: https://patchnext.com/advisories/cve-2025-29776 (revision 3, source checked 26 Oct 2026, 12:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: azle 0.30.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm azle: affected >= 0.27.0, < 0.30.0; fixed in 0.30.0 ## Suggested inspection (read-only) - `npm ls azle --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on azle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xc76-5pf9-mx8m (OSV record GHSA-xc76-5pf9-mx8m lists affected ranges: npm azle >=0.27.0 <0.30.0 (fixed)) - Verified: https://github.com/advisories/GHSA-xc76-5pf9-mx8m (GitHub-reviewed advisory GHSA-xc76-5pf9-mx8m lists affected ranges: npm azle >=0.27.0 <0.30.0) Commands are suggestions: review each one before running it.
Loading voting…