JS Html Sanitizer allows XSS when used with contentEditable
CVE-2025-29771GHSA-vhv4-fh94-jm5x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@jitbit/htmlsanitizer 2.0.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 2.0.3
- Fixed in
- 2.0.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vhv4-fh94-jm5x lists affected ranges: npm @jitbit/htmlsanitizer >=0 <2.0.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vhv4-fh94-jm5x lists affected ranges: npm @jitbit/htmlsanitizer >=0 <2.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2025-29771: 0.40% estimated exploitation activity in the next 30 days; percentile 34.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact XSS vulnerability when the sanitizer is used with a contentEditable element to set the elements innerHTML to a sanitized string produced by the package. If the code is particularly crafted to abuse the code beautifier, that runs AFTER sanitation. Patches Patched in version 2.0.3
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-vhv4-fh94-jm5x
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-vhv4-fh94-jm5x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-29771 Advisory: JS Html Sanitizer allows XSS when used with contentEditable IDs: CVE-2025-29771, GHSA-vhv4-fh94-jm5x Record: https://patchnext.com/advisories/cve-2025-29771 (revision 3, source checked 26 Oct 2026, 12:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @jitbit/htmlsanitizer 2.0.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @jitbit/htmlsanitizer: affected < 2.0.3; fixed in 2.0.3 ## Suggested inspection (read-only) - `npm ls @jitbit/htmlsanitizer --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @jitbit/htmlsanitizer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vhv4-fh94-jm5x (OSV record GHSA-vhv4-fh94-jm5x lists affected ranges: npm @jitbit/htmlsanitizer >=0 <2.0.3 (fixed)) - Verified: https://github.com/advisories/GHSA-vhv4-fh94-jm5x (GitHub-reviewed advisory GHSA-vhv4-fh94-jm5x lists affected ranges: npm @jitbit/htmlsanitizer >=0 <2.0.3) Commands are suggestions: review each one before running it.
Loading voting…