Skip to content

← Actionable
Medium, CVSS 5.4amended

pg-promise SQL Injection vulnerability

CVE-2025-29744GHSA-ff9h-848c-4xfj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pg-promise 11.5.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
EPSS
  • CVE-2025-29744: 0.22% estimated exploitation activity in the next 30 days; percentile 12.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

pg-promise before 11.5.5 is vulnerable to SQL Injection due to improper handling of negative numbers.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-ff9h-848c-4xfj

  2. Revision 1 · created ·

    Published from osv record GHSA-ff9h-848c-4xfj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-29744

Advisory: pg-promise SQL Injection vulnerability
IDs: CVE-2025-29744, GHSA-ff9h-848c-4xfj
Record: https://patchnext.com/advisories/cve-2025-29744 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pg-promise 11.5.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm pg-promise: affected < 11.5.5; fixed in 11.5.5

## Suggested inspection (read-only)
- `npm ls pg-promise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pg-promise.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-ff9h-848c-4xfj (OSV record GHSA-ff9h-848c-4xfj lists affected ranges: npm pg-promise >=0 <11.5.5 (fixed))
- Verified: https://github.com/advisories/GHSA-ff9h-848c-4xfj (GitHub-reviewed advisory GHSA-ff9h-848c-4xfj lists affected ranges: npm pg-promise >=0 <11.5.5)

Commands are suggestions: review each one before running it.

Loading voting…