PyTorch susceptible to local Denial of Service
CVE-2025-2953GHSA-3749-ghw9-m3mg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (torch 2.7.1rc1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI torch
- Affected
- < 2.7.1rc1
- Fixed in
- 2.7.1rc1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3749-ghw9-m3mg lists affected ranges: PyPI torch >=0 <2.7.1rc1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 1.9 · CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2025-2953: 0.26% estimated exploitation activity in the next 30 days; percentile 17.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability, which was classified as problematic, has been found in PyTorch 2.6.0+cu124. Affected by this issue is the function torch.mkldnnmaxpool2d. The manipulation leads to denial of service. An attack has to be approached locally. The exploit has been disclosed to the public and may be used.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3749-ghw9-m3mg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-2953 Advisory: PyTorch susceptible to local Denial of Service IDs: CVE-2025-2953, GHSA-3749-ghw9-m3mg Record: https://patchnext.com/advisories/cve-2025-2953 (revision 1, source checked 26 Oct 2026, 13:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 1.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: torch 2.7.1rc1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI torch: affected < 2.7.1rc1; fixed in 2.7.1rc1 ## Suggested inspection (read-only) - `python -m pip show torch`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on torch. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3749-ghw9-m3mg (GitHub-reviewed advisory GHSA-3749-ghw9-m3mg lists affected ranges: PyPI torch >=0 <2.7.1rc1) Commands are suggestions: review each one before running it.
Loading voting…