Skip to content

← Actionable
Medium, CVSS 5.3amended

Flowise Stored XSS vulnerability through logs in chatbot

CVE-2025-29192GHSA-7r4h-vmj9-wg42

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise 3.0.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm flowise

    Affected
    < 3.0.5
    Fixed in
    3.0.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N
EPSS
  • CVE-2025-29192: 0.41% estimated exploitation activity in the next 30 days; percentile 35.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description In the chat log, tags like input and form are allowed. This makes a potential vulnerability where an attacker could inject malicious HTML into the log via prompts. When an admin views the log containing the malicious HTML, the attacker could steal the admin's credentials or sensitive information with stored Cross Site Scripting. PoC If the above HTML code is entered, a very large img gets injected into the log. When an admin clicks the generated img, it alerts ‘XSS!!!’. It means stored xss is able in the chatbot. So when an admin clicks the img that generated by above html code, it sends a request, including credentials, to the attacker's IP. If attacker steal admin’s token, attacker can login as the admin in the apps. Poc Video poc Impact An attacker could hijack an admin account in published chatbot. This can allow attacker to view chat logs of other users and API keys.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-7r4h-vmj9-wg42

  2. Revision 1 · created ·

    Published from osv record GHSA-7r4h-vmj9-wg42

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-29192

Advisory: Flowise Stored XSS vulnerability through logs in chatbot
IDs: CVE-2025-29192, GHSA-7r4h-vmj9-wg42
Record: https://patchnext.com/advisories/cve-2025-29192 (revision 2, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flowise 3.0.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm flowise: affected < 3.0.5; fixed in 3.0.5

## Suggested inspection (read-only)
- `npm ls flowise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flowise.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7r4h-vmj9-wg42 (OSV record GHSA-7r4h-vmj9-wg42 lists affected ranges: npm flowise >=0 <3.0.5 (fixed))
- Verified: https://github.com/advisories/GHSA-7r4h-vmj9-wg42 (GitHub-reviewed advisory GHSA-7r4h-vmj9-wg42 lists affected ranges: npm flowise >=0 <3.0.5)

Commands are suggestions: review each one before running it.

Loading voting…