Mattermost vulnerable to Observable Timing Discrepancy
CVE-2025-27936GHSA-2j87-p623-8cc2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost/server/v8 10.5.2, 8.0.0-20250314142426-c049748b8863; github.com/mattermost/mattermost-plugin-msteams 2.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/mattermost/mattermost/server/v8
- Affected
- >= 10.5.0, < 10.5.2< 8.0.0-20250314142426-c049748b8863
- Fixed in
- 8.0.0-20250314142426-c049748b8863, 10.5.2
Go github.com/mattermost/mattermost-plugin-msteams
- Affected
- <= 1.15.0
- Fixed in
- 2.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2j87-p623-8cc2 lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=10.5.0 =0 =0 <=1.15.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2025-27936: 0.34% estimated exploitation activity in the next 30 days; percentile 28.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Mattermost Plugin MSTeams versions <2.1.0 and Mattermost Server versions 10.5.x <=10.5.1 with the MS Teams plugin enabled fail to perform constant time comparison on a MSTeams plugin webhook secret which allows an attacker to retrieve the webhook secret of the MSTeams plugin via a timing attack during webhook secret comparison.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2j87-p623-8cc2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-27936 Advisory: Mattermost vulnerable to Observable Timing Discrepancy IDs: CVE-2025-27936, GHSA-2j87-p623-8cc2 Record: https://patchnext.com/advisories/cve-2025-27936 (revision 1, source checked 26 Oct 2026, 15:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost/server/v8 10.5.2, 8.0.0-20250314142426-c049748b8863; github.com/mattermost/mattermost-plugin-msteams 2.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/mattermost/mattermost/server/v8: affected >= 10.5.0, < 10.5.2; < 8.0.0-20250314142426-c049748b8863; fixed in 8.0.0-20250314142426-c049748b8863, 10.5.2 - Go github.com/mattermost/mattermost-plugin-msteams: affected <= 1.15.0; fixed in 2.1.0 ## Suggested inspection (read-only) - Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager. - Go github.com/mattermost/mattermost-plugin-msteams: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-plugin-msteams. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2j87-p623-8cc2 (GitHub-reviewed advisory GHSA-2j87-p623-8cc2 lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=10.5.0 =0 =0 <=1.15.0) Commands are suggestions: review each one before running it.
Loading voting…