Apache Druid vulnerable to Server-Side Request Forgery, Cross-site Scripting, Open Redirect
CVE-2025-27888GHSA-2xcr-p767-f3rv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.druid:druid 32.0.1, 31.0.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.druid:druid
- Affected
- < 31.0.2>= 32.0.0, <= 32.0.0
- Fixed in
- 32.0.1, 31.0.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2xcr-p767-f3rv lists affected ranges: Maven org.apache.druid:druid >=0 =32.0.0 <=32.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.8 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:H/VI:L/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2025-27888: 1.79% estimated exploitation activity in the next 30 days; percentile 78.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Severity: medium (5.8) / important Server-Side Request Forgery (SSRF), Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting'), URL Redirection to Untrusted Site ('Open Redirect') vulnerability in Apache Druid. This issue affects all previous Druid versions. When using the Druid management proxy, a request that has a specially crafted URL could be used to redirect the request to an arbitrary server instead. This has the potential for XSS or XSRF. The user is required to be authenticated for this exploit. The management proxy is enabled in Druid's out-of-box configuration. It may be disabled to mitigate this vulnerability. If the management proxy is disabled, some web console features will not work properly, but core functionality is unaffected. Users are recommended to upgrade to Druid 31.0.2 or Druid 32.0.1, which fixes the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2xcr-p767-f3rv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-27888 Advisory: Apache Druid vulnerable to Server-Side Request Forgery, Cross-site Scripting, Open Redirect IDs: CVE-2025-27888, GHSA-2xcr-p767-f3rv Record: https://patchnext.com/advisories/cve-2025-27888 (revision 1, source checked 26 Oct 2026, 16:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.druid:druid 32.0.1, 31.0.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.druid:druid: affected < 31.0.2; >= 32.0.0, <= 32.0.0; fixed in 32.0.1, 31.0.2 ## Suggested inspection (read-only) - Maven org.apache.druid:druid: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.druid:druid. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2xcr-p767-f3rv (GitHub-reviewed advisory GHSA-2xcr-p767-f3rv lists affected ranges: Maven org.apache.druid:druid >=0 =32.0.0 <=32.0.0) Commands are suggestions: review each one before running it.
Loading voting…