Skip to content

← Actionable
High, CVSS 8.8

Apache Kafka Deserialization of Untrusted Data vulnerability

CVE-2025-27818GHSA-76qp-h5mr-frr4

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.apache.kafka:kafka_2.13

    Affected
    >= 2.4.0, < 3.9.1
    Fixed in
    3.9.1
  • Maven org.apache.kafka:kafka_2.12

    Affected
    >= 2.3.0, < 3.9.1
    Fixed in
    3.9.1
  • Maven org.apache.kafka:kafka_2.11

    Affected
    >= 2.3.0, <= 2.4.1
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2025-27818: 1.07% estimated exploitation activity in the next 30 days; percentile 64.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A possible security vulnerability has been identified in Apache Kafka. This requires access to a alterConfig to the cluster resource, or Kafka Connect worker, and the ability to create/modify connectors on it with an arbitrary Kafka client SASL JAAS config and a SASL-based security protocol, which has been possible on Kafka clusters since Apache Kafka 2.0.0 (Kafka Connect 2.3.0). When configuring the broker via config file or AlterConfig command, or connector via the Kafka Kafka Connect REST API, an authenticated operator can set the sasl.jaas.config property for any of the connector's Kafka clients to "com.sun.security.auth.module.LdapLoginModule", which can be done via the producer.override.sasl.jaas.config, consumer.override.sasl.jaas.config, or admin.override.sasl.jaas.config properties. This will allow the server to connect to the attacker's LDAP server and deserialize the LDAP response, which the attacker can use to execute java deserialization gadget chains on the Kafka…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-76qp-h5mr-frr4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-27818

Advisory: Apache Kafka Deserialization of Untrusted Data vulnerability
IDs: CVE-2025-27818, GHSA-76qp-h5mr-frr4
Record: https://patchnext.com/advisories/cve-2025-27818 (revision 1, source checked 26 Oct 2026, 16:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: org.apache.kafka:kafka_2.13 3.9.1; org.apache.kafka:kafka_2.12 3.9.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.kafka:kafka_2.13: affected >= 2.4.0, < 3.9.1; fixed in 3.9.1
- Maven org.apache.kafka:kafka_2.12: affected >= 2.3.0, < 3.9.1; fixed in 3.9.1
- Maven org.apache.kafka:kafka_2.11: affected >= 2.3.0, <= 2.4.1

## Suggested inspection (read-only)
- Maven org.apache.kafka:kafka_2.13: check the installed version with your package manager.
- Maven org.apache.kafka:kafka_2.12: check the installed version with your package manager.
- Maven org.apache.kafka:kafka_2.11: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.kafka:kafka_2.13, org.apache.kafka:kafka_2.12, org.apache.kafka:kafka_2.11.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-76qp-h5mr-frr4 (GitHub-reviewed advisory GHSA-76qp-h5mr-frr4 lists affected ranges: Maven org.apache.kafka:kafka_2.11 >=2.3.0 =2.3.0 =2.4.0 <3.9.1)

Commands are suggestions: review each one before running it.

Loading voting…