Vega vulnerable to Cross-site Scripting via RegExp.prototype[@@replace]
CVE-2025-27793GHSA-963h-3v39-3pqf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vega 5.32.0; vega-functions 5.17.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm vega
- Affected
- < 5.32.0
- Fixed in
- 5.32.0
npm vega-functions
- Affected
- < 5.17.0
- Fixed in
- 5.17.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-963h-3v39-3pqf lists affected ranges: npm vega >=0 =0 <5.17.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-963h-3v39-3pqf lists affected ranges: npm vega >=0 =0 <5.17.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2025-27793: 0.52% estimated exploitation activity in the next 30 days; percentile 44.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Users running Vega/Vega-lite JSON definitions could run unexpected JavaScript code when drawing graphs, unless the library is used with the vega-interpreter. Workarounds - Use vega with expression interpreter - Upgrade to a newer Vega version (5.32.0) POC Summary Calling replace with a RegExp-like pattern calls RegExp.prototype[@@replace], which can then call an attacker-controlled exec function. POC Details Consider the function call replace('foo', {proto: /h/.constructor.prototype, global: false}). Since pattern has RegExp.prototype[@@replace], pattern.exec('foo') winds up being called. The resulting malicious call looks like this: Since functions cannot be returned from this, an attacker that wishes to escalate to XSS must abuse event.view to gain access to eval. Reproduction steps
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-963h-3v39-3pqf
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-963h-3v39-3pqf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-27793 Advisory: Vega vulnerable to Cross-site Scripting via RegExp.prototype[@@replace] IDs: CVE-2025-27793, GHSA-963h-3v39-3pqf Record: https://patchnext.com/advisories/cve-2025-27793 (revision 3, source checked 26 Oct 2026, 12:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vega 5.32.0; vega-functions 5.17.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm vega: affected < 5.32.0; fixed in 5.32.0 - npm vega-functions: affected < 5.17.0; fixed in 5.17.0 ## Suggested inspection (read-only) - `npm ls vega --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls vega-functions --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vega, vega-functions. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-963h-3v39-3pqf (OSV record GHSA-963h-3v39-3pqf lists affected ranges: npm vega >=0 =0 <5.17.0 (fixed)) - Verified: https://github.com/advisories/GHSA-963h-3v39-3pqf (GitHub-reviewed advisory GHSA-963h-3v39-3pqf lists affected ranges: npm vega >=0 =0 <5.17.0) Commands are suggestions: review each one before running it.
Loading voting…