Babel has inefficient RegExp complexity in generated code with .replace when transpiling named capturing groups
CVE-2025-27789GHSA-968p-4wvh-cqc8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@babel/runtime-corejs3 8.0.0-alpha.17, 7.26.10; @babel/helpers 8.0.0-alpha.17, 7.26.10; @babel/runtime-corejs2 8.0.0-alpha.17, 7.26.10; @babel/runtime 8.0.0-alpha.17, 7.26.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 7.26.10>= 8.0.0-alpha.0, < 8.0.0-alpha.17
- Fixed in
- 7.26.10, 8.0.0-alpha.17
npm @babel/helpers
- Affected
- < 7.26.10>= 8.0.0-alpha.0, < 8.0.0-alpha.17
- Fixed in
- 7.26.10, 8.0.0-alpha.17
- Affected
- < 7.26.10>= 8.0.0-alpha.0, < 8.0.0-alpha.17
- Fixed in
- 7.26.10, 8.0.0-alpha.17
npm @babel/runtime
- Affected
- < 7.26.10>= 8.0.0-alpha.0, < 8.0.0-alpha.17
- Fixed in
- 7.26.10, 8.0.0-alpha.17
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-968p-4wvh-cqc8 lists affected ranges: npm @babel/helpers >=0 =8.0.0-alpha.0 =0 =8.0.0-alpha.0 =0 =8.0.0-alpha.0 =0 =8.0.0-alpha.0 <8.0.0-alpha.17 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.2 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2025-27789: 0.56% estimated exploitation activity in the next 30 days; percentile 46.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When using Babel to compile regular expression named capturing groups, Babel will generate a polyfill for the `.replace` method that has quadratic complexity on some specific replacement pattern strings (i.e. the second argument passed to `.replace`). Your generated code is vulnerable if _all_ the following conditions are true: - You use Babel to compile regular expression named capturing groups - You use the `.replace` method on a regular expression that contains named capturing groups - Your code uses untrusted strings as the second argument of `.replace` If you are using `@babel/preset-env` with the `targets` option, the transform that injects the vulnerable code is automatically enabled if: - you use…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from osv record GHSA-968p-4wvh-cqc8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-27789 Advisory: Babel has inefficient RegExp complexity in generated code with .replace when transpiling named capturing groups IDs: CVE-2025-27789, GHSA-968p-4wvh-cqc8 Record: https://patchnext.com/advisories/cve-2025-27789 (revision 1, source checked 24 Oct 2026, 04:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @babel/runtime-corejs3 8.0.0-alpha.17, 7.26.10; @babel/helpers 8.0.0-alpha.17, 7.26.10; @babel/runtime-corejs2 8.0.0-alpha.17, 7.26.10; @babel/runtime 8.0.0-alpha.17, 7.26.10. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @babel/runtime-corejs3: affected < 7.26.10; >= 8.0.0-alpha.0, < 8.0.0-alpha.17; fixed in 7.26.10, 8.0.0-alpha.17 - npm @babel/helpers: affected < 7.26.10; >= 8.0.0-alpha.0, < 8.0.0-alpha.17; fixed in 7.26.10, 8.0.0-alpha.17 - npm @babel/runtime-corejs2: affected < 7.26.10; >= 8.0.0-alpha.0, < 8.0.0-alpha.17; fixed in 7.26.10, 8.0.0-alpha.17 - npm @babel/runtime: affected < 7.26.10; >= 8.0.0-alpha.0, < 8.0.0-alpha.17; fixed in 7.26.10, 8.0.0-alpha.17 ## Suggested inspection (read-only) - `npm ls @babel/runtime-corejs3 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @babel/helpers --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @babel/runtime-corejs2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @babel/runtime --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @babel/runtime-corejs3, @babel/helpers, @babel/runtime-corejs2, @babel/runtime. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-968p-4wvh-cqc8 (OSV record GHSA-968p-4wvh-cqc8 lists affected ranges: npm @babel/helpers >=0 =8.0.0-alpha.0 =0 =8.0.0-alpha.0 =0 =8.0.0-alpha.0 =0 =8.0.0-alpha.0 <8.0.0-alpha.17 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…