The SimpleSAMLphp SAML2 library incorrectly verifies signatures for HTTP-Redirect binding
CVE-2025-27773GHSA-46r4-f8gj-xg56
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (simplesamlphp/saml2-legacy 4.17.0; simplesamlphp/saml2 5.0.0-alpha.20, 4.17.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist simplesamlphp/saml2-legacy
- Affected
- <= 4.16.15
- Fixed in
- 4.17.0
Packagist simplesamlphp/saml2
- Affected
- >= 5.0.0-alpha.1, <= 5.0.0-alpha.19<= 4.16.15
- Fixed in
- 4.17.0, 5.0.0-alpha.20
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-46r4-f8gj-xg56 lists affected ranges: Packagist simplesamlphp/saml2 >=5.0.0-alpha.1 =0 =0 <=4.16.15
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
- EPSS
- CVE-2025-27773: 0.41% estimated exploitation activity in the next 30 days; percentile 35.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary There's a signature confusion attack in the HTTPRedirect binding. An attacker with any signed SAMLResponse via the HTTP-Redirect binding can cause the application to accept an unsigned message. I believe that it exists for v4 only. I have not yet developed a PoC. V5 is well designed and instead builds the signed query from the same message that will be consumed. Details What is verified The data['SignedQuery'] is the string that will be verified by the public key. It is defined here: https://github.com/simplesamlphp/saml2/blob/9545abd0d9d48388f2fa00469c5c1e0294f0303e/src/SAML2/HTTPRedirect.php#L178-L217 THe code will iterate through each parameter name. Notably, sigQuery is overridden each time when processing, making the last of SAMLRequest/SAMLResponse used for sigQuery. For example, given: SAMLRequest=a&SAMLResponse=idpsigned SAMLResponse=idpsigned will be set as sigQuery, then later verified What is actually processed Processing uses SAMLRequest parameter value first, (if…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-46r4-f8gj-xg56
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-27773 Advisory: The SimpleSAMLphp SAML2 library incorrectly verifies signatures for HTTP-Redirect binding IDs: CVE-2025-27773, GHSA-46r4-f8gj-xg56 Record: https://patchnext.com/advisories/cve-2025-27773 (revision 1, source checked 26 Oct 2026, 14:33 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: simplesamlphp/saml2-legacy 4.17.0; simplesamlphp/saml2 5.0.0-alpha.20, 4.17.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist simplesamlphp/saml2-legacy: affected <= 4.16.15; fixed in 4.17.0 - Packagist simplesamlphp/saml2: affected >= 5.0.0-alpha.1, <= 5.0.0-alpha.19; <= 4.16.15; fixed in 4.17.0, 5.0.0-alpha.20 ## Suggested inspection (read-only) - Packagist simplesamlphp/saml2-legacy: check the installed version with your package manager. - Packagist simplesamlphp/saml2: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on simplesamlphp/saml2-legacy, simplesamlphp/saml2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-46r4-f8gj-xg56 (GitHub-reviewed advisory GHSA-46r4-f8gj-xg56 lists affected ranges: Packagist simplesamlphp/saml2 >=5.0.0-alpha.1 =0 =0 <=4.16.15) Commands are suggestions: review each one before running it.
Loading voting…