com.xwiki.confluencepro:application-confluence-migrator-pro-ui Remote Code Execution via unescaped translations
CVE-2025-27603GHSA-6qvp-39mm-95v8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.xwiki.confluencepro:application-confluence-migrator-pro-ui 1.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.xwiki.confluencepro:application-confluence-migrator-pro-ui
- Affected
- >= 1.0, < 1.2.0
- Fixed in
- 1.2.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6qvp-39mm-95v8 lists affected ranges: Maven com.xwiki.confluencepro:application-confluence-migrator-pro-ui >=1.0 <1.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2025-27603: 0.66% estimated exploitation activity in the next 30 days; percentile 51.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A user that doesn't have programming rights can execute arbitrary code when creating a page using the Migration Page template. A possible attack vector is the following: Create a page and add the following content: Use the object editor to add an object of type XWiki.TranslationDocumentClass with scope USER. Access an unexisting page using the MigrationTemplate It is expected that {{/html}} {{async async="true" cached="false" context="doc.reference"}}{{groovy}}println("hello from groovy!"){{/groovy}}{{/async}} will be present on the page, however, hello from groovy will be printed. Patches The issue will be fixed as part of v1.2. The fix was added with commit 35cef22 Workarounds There are no known workarounds besides upgrading. References No references.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6qvp-39mm-95v8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-27603 Advisory: com.xwiki.confluencepro:application-confluence-migrator-pro-ui Remote Code Execution via unescaped translations IDs: CVE-2025-27603, GHSA-6qvp-39mm-95v8 Record: https://patchnext.com/advisories/cve-2025-27603 (revision 1, source checked 26 Oct 2026, 16:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.xwiki.confluencepro:application-confluence-migrator-pro-ui 1.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.xwiki.confluencepro:application-confluence-migrator-pro-ui: affected >= 1.0, < 1.2.0; fixed in 1.2.0 ## Suggested inspection (read-only) - Maven com.xwiki.confluencepro:application-confluence-migrator-pro-ui: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.xwiki.confluencepro:application-confluence-migrator-pro-ui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6qvp-39mm-95v8 (GitHub-reviewed advisory GHSA-6qvp-39mm-95v8 lists affected ranges: Maven com.xwiki.confluencepro:application-confluence-migrator-pro-ui >=1.0 <1.2.0) Commands are suggestions: review each one before running it.
Loading voting…