Oxidized Web RANCID migration page allows unauthenticated user to gain control over Linux user account
CVE-2025-27590GHSA-jx6p-9c26-g373
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (oxidized-web 0.15.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems oxidized-web
- Affected
- < 0.15.0
- Fixed in
- 0.15.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jx6p-9c26-g373 lists affected ranges: RubyGems oxidized-web >=0 <0.15.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.0 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2025-27590: 27.57% estimated exploitation activity in the next 30 days; percentile 98.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In oxidized-web (aka Oxidized Web) before 0.15.0, the RANCID migration page allows an unauthenticated user to gain control over the Linux user account that is running oxidized-web.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jx6p-9c26-g373
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-27590 Advisory: Oxidized Web RANCID migration page allows unauthenticated user to gain control over Linux user account IDs: CVE-2025-27590, GHSA-jx6p-9c26-g373 Record: https://patchnext.com/advisories/cve-2025-27590 (revision 1, source checked 26 Oct 2026, 15:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: oxidized-web 0.15.0. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems oxidized-web: affected < 0.15.0; fixed in 0.15.0 ## Suggested inspection (read-only) - RubyGems oxidized-web: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on oxidized-web. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jx6p-9c26-g373 (GitHub-reviewed advisory GHSA-jx6p-9c26-g373 lists affected ranges: RubyGems oxidized-web >=0 <0.15.0) Commands are suggestions: review each one before running it.
Loading voting…