Apache Airflow exposes sensitive information in its log files
CVE-2025-27555GHSA-8r55-rv5w-6pfm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow 2.11.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-airflow
- Affected
- < 2.11.1
- Fixed in
- 2.11.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8r55-rv5w-6pfm lists affected ranges: PyPI apache-airflow >=0 <2.11.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8r55-rv5w-6pfm lists affected ranges: PyPI apache-airflow >=0 <2.11.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2025-27555: 0.42% estimated exploitation activity in the next 30 days; percentile 36.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Airflow versions before 2.11.1 have a vulnerability that allows authenticated users with audit log access to see sensitive values in audit logs which they should not see. When sensitive connection parameters were set via airflow CLI, values of those variables appeared in the audit log and were stored unencrypted in the Airflow database. While this risk is limited to users with audit log access, it is recommended to upgrade to Airflow 2.11.1 or a later version, which addresses this issue. Users who previously used the CLI to set connections should manually delete entries with those connection sensitive values from the log table. This is similar but not the same issue as CVE-2024-50378
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-8r55-rv5w-6pfm
- Revision 1 · created ·
Published from osv record GHSA-8r55-rv5w-6pfm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-27555 Advisory: Apache Airflow exposes sensitive information in its log files IDs: CVE-2025-27555, GHSA-8r55-rv5w-6pfm Record: https://patchnext.com/advisories/cve-2025-27555 (revision 2, source checked 26 Oct 2026, 13:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache-airflow 2.11.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-airflow: affected < 2.11.1; fixed in 2.11.1 ## Suggested inspection (read-only) - `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-airflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8r55-rv5w-6pfm (OSV record GHSA-8r55-rv5w-6pfm lists affected ranges: PyPI apache-airflow >=0 <2.11.1 (fixed)) - Verified: https://github.com/advisories/GHSA-8r55-rv5w-6pfm (GitHub-reviewed advisory GHSA-8r55-rv5w-6pfm lists affected ranges: PyPI apache-airflow >=0 <2.11.1) Commands are suggestions: review each one before running it.
Loading voting…