Apache InLong: JDBC Vulnerability during verification processing
CVE-2025-27522GHSA-r324-vgr5-73c9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.inlong:manager-pojo 2.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.inlong:manager-pojo
- Affected
- >= 1.13.0, < 2.2.0
- Fixed in
- 2.2.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r324-vgr5-73c9 lists affected ranges: Maven org.apache.inlong:manager-pojo >=1.13.0 <2.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2025-27522: 0.90% estimated exploitation activity in the next 30 days; percentile 59.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Deserialization of Untrusted Data vulnerability in Apache InLong. This issue affects Apache InLong: from 1.13.0 through 2.1.0. This vulnerability is a secondary mining bypass for CVE-2024-26579. Users are advised to upgrade to Apache InLong's 2.2.0 or cherry-pick [1] to solve it. [1] https://github.com/apache/inlong/pull/11732
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-r324-vgr5-73c9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-27522 Advisory: Apache InLong: JDBC Vulnerability during verification processing IDs: CVE-2025-27522, GHSA-r324-vgr5-73c9 Record: https://patchnext.com/advisories/cve-2025-27522 (revision 1, source checked 26 Oct 2026, 16:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.inlong:manager-pojo 2.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.inlong:manager-pojo: affected >= 1.13.0, < 2.2.0; fixed in 2.2.0 ## Suggested inspection (read-only) - Maven org.apache.inlong:manager-pojo: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.inlong:manager-pojo. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r324-vgr5-73c9 (GitHub-reviewed advisory GHSA-r324-vgr5-73c9 lists affected ranges: Maven org.apache.inlong:manager-pojo >=1.13.0 <2.2.0) Commands are suggestions: review each one before running it.
Loading voting…