Skip to content

← Actionable
Medium, CVSS 6.9

Laravel has a File Validation Bypass

CVE-2025-27515GHSA-78fx-h6xr-vch4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (laravel/framework 12.1.1, 11.44.1, 10.48.29), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist laravel/framework

    Affected
    >= 12.0.0, < 12.1.1>= 11.0.0, < 11.44.1< 10.48.29
    Fixed in
    11.44.1, 12.1.1, 10.48.29

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-27515: 0.75% estimated exploitation activity in the next 30 days; percentile 54.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

When using wildcard validation to validate a given file or image field array (files.), a user-crafted malicious request could potentially bypass the validation rules.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-78fx-h6xr-vch4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-27515

Advisory: Laravel has a File Validation Bypass
IDs: CVE-2025-27515, GHSA-78fx-h6xr-vch4
Record: https://patchnext.com/advisories/cve-2025-27515 (revision 1, source checked 26 Oct 2026, 14:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: laravel/framework 12.1.1, 11.44.1, 10.48.29. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist laravel/framework: affected >= 12.0.0, < 12.1.1; >= 11.0.0, < 11.44.1; < 10.48.29; fixed in 11.44.1, 12.1.1, 10.48.29

## Suggested inspection (read-only)
- Packagist laravel/framework: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on laravel/framework.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-78fx-h6xr-vch4 (GitHub-reviewed advisory GHSA-78fx-h6xr-vch4 lists affected ranges: Packagist laravel/framework >=12.0.0 =11.0.0 =0 <10.48.29)

Commands are suggestions: review each one before running it.

Loading voting…