Skip to content

← Actionable
High, CVSS 7.2

GeoServer DB2 DataStore Extension has a JNDI Vulnerability via Store Connection

CVE-2025-27511GHSA-g628-r368-6vh7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.geoserver.extension:gs-db2 2.27.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2025-27511: 1.07% estimated exploitation activity in the next 30 days; percentile 64.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Administrator can perform JNDI attack through specially crafted DB2 jdbc url leading to Remote Code Execution (RCE). Impact If GeoServer has DB2 extension installed, this vulnerability can lead to executing arbitrary code. Details Authenticated users can access Vector Data Sources page to creating a new data store through db2 jdbc connection, performing JNDI attack due to unrestricted connection parameters, and then achieve RCE with deserialization of untrusted data. Remediation This issue has been fixed in this release: https://github.com/geoserver/geoserver/releases/tag/2.27.0. References https://osgeo-org.atlassian.net/browse/GEOT-7725 https://nvd.nist.gov/vuln/detail/cve-2023-27867

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-g628-r368-6vh7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-27511

Advisory: GeoServer DB2 DataStore Extension has a JNDI Vulnerability via Store Connection
IDs: CVE-2025-27511, GHSA-g628-r368-6vh7
Record: https://patchnext.com/advisories/cve-2025-27511 (revision 1, source checked 26 Oct 2026, 16:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.geoserver.extension:gs-db2 2.27.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.geoserver.extension:gs-db2: affected < 2.27.0; fixed in 2.27.0

## Suggested inspection (read-only)
- Maven org.geoserver.extension:gs-db2: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.geoserver.extension:gs-db2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-g628-r368-6vh7 (GitHub-reviewed advisory GHSA-g628-r368-6vh7 lists affected ranges: Maven org.geoserver.extension:gs-db2 >=0 <2.27.0)

Commands are suggestions: review each one before running it.

Loading voting…