Skip to content

← Actionable
Critical, CVSS 9.3

Fleet has SAML authentication vulnerability due to improper SAML response validation

CVE-2025-27509GHSA-52jx-g6m5-h735

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/fleetdm/fleet/v4 4.64.2, 4.63.2, 4.62.4, 4.58.1, 4.53.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/fleetdm/fleet/v4

    Affected
    >= 4.64.0, < 4.64.2>= 4.63.0, < 4.63.2>= 4.62.0, < 4.62.4>= 4.54.0, < 4.58.1< 4.53.2
    Fixed in
    4.58.1, 4.63.2, 4.62.4, 4.53.2, 4.64.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-27509: 0.67% estimated exploitation activity in the next 30 days; percentile 52.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A vulnerability in Fleet’s SAML authentication handling could allow an attacker to forge authentication assertions and gain unauthorized access to Fleet. In certain configurations, this could result in the creation of new user accounts, including administrative accounts. This issue affects Fleet deployments using single sign-on (SSO). Impact In vulnerable versions of Fleet, an attacker could craft a specially-formed SAML response to: - Forge authentication assertions, potentially impersonating legitimate users. - If Just-In-Time (JIT) provisioning is enabled, the attacker could provision a new administrative user account. - If MDM enrollment is enabled, certain endpoints could be used to create new accounts tied to forged assertions. This could allow unauthorized access to Fleet, including administrative access, visibility into device data, and modification of configuration. Patches This issue is addressed in commit fc96cc4 and is available in Fleet version 4.64.2. The…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-52jx-g6m5-h735

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-27509

Advisory: Fleet has SAML authentication vulnerability due to improper SAML response validation
IDs: CVE-2025-27509, GHSA-52jx-g6m5-h735
Record: https://patchnext.com/advisories/cve-2025-27509 (revision 1, source checked 26 Oct 2026, 15:14 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/fleetdm/fleet/v4 4.64.2, 4.63.2, 4.62.4, 4.58.1, 4.53.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/fleetdm/fleet/v4: affected >= 4.64.0, < 4.64.2; >= 4.63.0, < 4.63.2; >= 4.62.0, < 4.62.4; >= 4.54.0, < 4.58.1; < 4.53.2; fixed in 4.58.1, 4.63.2, 4.62.4, 4.53.2, 4.64.2

## Suggested inspection (read-only)
- Go github.com/fleetdm/fleet/v4: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/fleetdm/fleet/v4.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-52jx-g6m5-h735 (GitHub-reviewed advisory GHSA-52jx-g6m5-h735 lists affected ranges: Go github.com/fleetdm/fleet/v4 >=4.64.0 =4.63.0 =4.62.0 =4.54.0 =0 <4.53.2)

Commands are suggestions: review each one before running it.

Loading voting…