Skip to content

← Actionable
High, CVSS 7.5

Emissary May Use a Broken or Risky Cryptographic Algorithm

CVE-2025-27508GHSA-hw43-fcmm-3m5g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (gov.nsa.emissary:emissary 8.24.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2025-27508: 0.21% estimated exploitation activity in the next 30 days; percentile 11.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The ChecksumCalculator class within allows for hashing and checksum generation, but it includes or defaults to algorithms that are no longer recommended for secure cryptographic use cases (e.g., SHA-1, CRC32, and SSDEEP). These algorithms, while possibly valid for certain non-security-critical tasks, can expose users to security risks if used in scenarios where strong cryptographic guarantees are required. Requirement from NIST Requirement from NIST regarding SHA1 https://csrc.nist.gov/projects/hash-functions#:~:text=NIST%20deprecated%20the%20use%20of,use%20of%20the%20SHA%2D1. Federal agencies should use SHA-2 or SHA-3 as an alternative to SHA-1. Further guidance will be available soon. Send questions on the transition to sha-1-transition@nist.gov. https://www.nist.gov/news-events/news/2022/12/nist-retires-sha-1-cryptographic-algorithm Mitigation and Fix Make it clear to developers and users that the ChecksumCalculator is specific to the "Known File Filter" (KFF) document…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hw43-fcmm-3m5g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-27508

Advisory: Emissary May Use a Broken or Risky Cryptographic Algorithm
IDs: CVE-2025-27508, GHSA-hw43-fcmm-3m5g
Record: https://patchnext.com/advisories/cve-2025-27508 (revision 1, source checked 26 Oct 2026, 16:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: gov.nsa.emissary:emissary 8.24.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven gov.nsa.emissary:emissary: affected <= 8.23.0; fixed in 8.24.0

## Suggested inspection (read-only)
- Maven gov.nsa.emissary:emissary: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gov.nsa.emissary:emissary.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hw43-fcmm-3m5g (GitHub-reviewed advisory GHSA-hw43-fcmm-3m5g lists affected ranges: Maven gov.nsa.emissary:emissary >=0 <=8.23.0)

Commands are suggestions: review each one before running it.

Loading voting…