NocoDB Vulnerable to Reflected Cross-Site Scripting on Reset Password Page
CVE-2025-27506GHSA-wf6c-hrhf-86cw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nocodb 0.258.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm nocodb
- Affected
- < 0.258.0
- Fixed in
- 0.258.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wf6c-hrhf-86cw lists affected ranges: npm nocodb >=0 <0.258.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wf6c-hrhf-86cw lists affected ranges: npm nocodb >=0 <0.258.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2025-27506: 0.71% estimated exploitation activity in the next 30 days; percentile 53.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The API endpoint related to the password reset function is vulnerable to Reflected Cross-Site-Scripting. Details Throughout the source-code analysis, it has been found that the endpoint /api/v1/db/auth/password/reset/:tokenId is vulnerable to Reflected Cross-Site-Scripting. The flaw occurs due to implementation of the client-side template engine ejs, specifically on file resetPassword.ts where the template is using the insecure function “<%-“ https://github.com/nocodb/nocodb/blob/ba5a191b33259d984fc92df225f7d82ede2ddb56/packages/nocodb/src/modules/auth/ui/auth/resetPassword.ts#L71 which is rendered by the function renderPasswordReset: https://github.com/nocodb/nocodb/blob/ba5a191b33259d984fc92df225f7d82ede2ddb56/packages/nocodb/src/modules/auth/auth.controller.ts#L251 PoC Send the request below to a vulnerable instance: /api/v1/db/auth/password/reset/asdsad%3C%2F%73%63%72%69%70%74%3E%3C%73%63%72%69%70%74%3E%61%6C%65%72%74%28%31%29%3C%2F%73%63%72%69%70%74%3E/ Impact The…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-wf6c-hrhf-86cw
- Revision 1 · created ·
Published from osv record GHSA-wf6c-hrhf-86cw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-27506 Advisory: NocoDB Vulnerable to Reflected Cross-Site Scripting on Reset Password Page IDs: CVE-2025-27506, GHSA-wf6c-hrhf-86cw Record: https://patchnext.com/advisories/cve-2025-27506 (revision 2, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nocodb 0.258.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm nocodb: affected < 0.258.0; fixed in 0.258.0 ## Suggested inspection (read-only) - `npm ls nocodb --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nocodb. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wf6c-hrhf-86cw (OSV record GHSA-wf6c-hrhf-86cw lists affected ranges: npm nocodb >=0 <0.258.0 (fixed)) - Verified: https://github.com/advisories/GHSA-wf6c-hrhf-86cw (GitHub-reviewed advisory GHSA-wf6c-hrhf-86cw lists affected ranges: npm nocodb >=0 <0.258.0) Commands are suggestions: review each one before running it.
Loading voting…