Skip to content

← Actionable
High, CVSS 7.5

Goroutine Leak in Abacus SSE Implementation

CVE-2025-27421GHSA-vh64-54px-qgf8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/jasonlovesdoggo/abacus 0.0.0-20250302043802-898ff1204e11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2025-27421: 0.41% estimated exploitation activity in the next 30 days; percentile 35.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Goroutine Leak in Abacus SSE Implementation Summary A critical goroutine leak vulnerability has been identified in the Abacus server's Server-Sent Events (SSE) implementation. The issue occurs when clients disconnect from the /stream endpoint, as the server fails to properly clean up resources and terminate associated goroutines. This leads to resource exhaustion where the server continues running but eventually stops accepting new SSE connections while maintaining high memory usage. The vulnerability specifically involves improper channel cleanup in the event handling mechanism, causing goroutines to remain blocked indefinitely. POC Impact This vulnerability affects all versions of Abacus prior to v1.4.0. The issue causes: - Permanent unresponsiveness of the /stream endpoint after prolonged use - Memory growth that stabilizes at a high level but prevents proper functionality - Selective denial of service affecting only SSE connections while other endpoints remain functional -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vh64-54px-qgf8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-27421

Advisory: Goroutine Leak in Abacus SSE Implementation
IDs: CVE-2025-27421, GHSA-vh64-54px-qgf8
Record: https://patchnext.com/advisories/cve-2025-27421 (revision 1, source checked 26 Oct 2026, 15:09 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/jasonlovesdoggo/abacus 0.0.0-20250302043802-898ff1204e11. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/jasonlovesdoggo/abacus: affected < 0.0.0-20250302043802-898ff1204e11; fixed in 0.0.0-20250302043802-898ff1204e11

## Suggested inspection (read-only)
- Go github.com/jasonlovesdoggo/abacus: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/jasonlovesdoggo/abacus.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vh64-54px-qgf8 (GitHub-reviewed advisory GHSA-vh64-54px-qgf8 lists affected ranges: Go github.com/jasonlovesdoggo/abacus >=0 <0.0.0-20250302043802-898ff1204e11)

Commands are suggestions: review each one before running it.

Loading voting…