Skip to content

← Actionable
Medium, CVSS 4.8amended

Manifest Uses a One-Way Hash without a Salt

CVE-2025-27408GHSA-h8h6-7752-g28c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (manifest 4.9.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm manifest

    Affected
    < 4.9.2
    Fixed in
    4.9.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2025-27408: 0.16% estimated exploitation activity in the next 30 days; percentile 4.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Manifest employs a weak password hashing implementation that uses SHA3 without a salt. This exposes user passwords to a higher risk of being cracked if an attacker gains access to the database. Without the use of a salt, identical passwords across multiple users will result in the same hash, making it easier for attackers to identify and exploit patterns, thereby accelerating the cracking process. Details Analysis of the application source code reveals that user passwords are hashed using the SHA3 algorithm without implementing a unique salt per user. This approach results in deterministic password hashes, which can be identified by comparing the hashes for users with matching credentials. PoC 1. Create two users with the same password (it could be admin or any other authenticatable entity) 2. Extract their password hashes from the database 3. Verify that both hashes are identical, confirming the absence of unique salts Impact This is a cryptographic weakness vulnerability…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-h8h6-7752-g28c

  2. Revision 1 · created ·

    Published from osv record GHSA-h8h6-7752-g28c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-27408

Advisory: Manifest Uses a One-Way Hash without a Salt
IDs: CVE-2025-27408, GHSA-h8h6-7752-g28c
Record: https://patchnext.com/advisories/cve-2025-27408 (revision 2, source checked 26 Oct 2026, 12:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: manifest 4.9.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm manifest: affected < 4.9.2; fixed in 4.9.2

## Suggested inspection (read-only)
- `npm ls manifest --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on manifest.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-h8h6-7752-g28c (OSV record GHSA-h8h6-7752-g28c lists affected ranges: npm manifest >=0 <4.9.2 (fixed))
- Verified: https://github.com/advisories/GHSA-h8h6-7752-g28c (GitHub-reviewed advisory GHSA-h8h6-7752-g28c lists affected ranges: npm manifest >=0 <4.9.2)

Commands are suggestions: review each one before running it.

Loading voting…