Skip to content

← Actionable
Medium, CVSS 6.3

CGI has Denial of Service (DoS) potential in Cookie.parse

CVE-2025-27219GHSA-gh9q-2xrm-x6qv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (cgi 0.4.2, 0.3.7, 0.3.5.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems cgi

    Affected
    < 0.3.5.1>= 0.3.6, <= 0.3.6>= 0.4.0, < 0.4.2
    Fixed in
    0.3.5.1, 0.3.7, 0.4.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-27219: 0.85% estimated exploitation activity in the next 30 days; percentile 58.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

There is a possibility for DoS by in the cgi gem. This vulnerability has been assigned the CVE identifier CVE-2025-27219. We recommend upgrading the cgi gem. Details CGI::Cookie.parse took super-linear time to parse a cookie string in some cases. Feeding a maliciously crafted cookie string into the method could lead to a Denial of Service. Please update CGI gem to version 0.3.5.1, 0.3.7, 0.4.2 or later. Affected versions cgi gem versions <= 0.3.5, 0.3.6, 0.4.0 and 0.4.1. Credits Thanks to lio346 for discovering this issue. Also thanks to mame for fixing this vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gh9q-2xrm-x6qv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-27219

Advisory: CGI has Denial of Service (DoS) potential in Cookie.parse
IDs: CVE-2025-27219, GHSA-gh9q-2xrm-x6qv
Record: https://patchnext.com/advisories/cve-2025-27219 (revision 1, source checked 26 Oct 2026, 15:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: cgi 0.4.2, 0.3.7, 0.3.5.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems cgi: affected < 0.3.5.1; >= 0.3.6, <= 0.3.6; >= 0.4.0, < 0.4.2; fixed in 0.3.5.1, 0.3.7, 0.4.2

## Suggested inspection (read-only)
- RubyGems cgi: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on cgi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gh9q-2xrm-x6qv (GitHub-reviewed advisory GHSA-gh9q-2xrm-x6qv lists affected ranges: RubyGems cgi >=0 =0.3.6 =0.4.0 <0.4.2)

Commands are suggestions: review each one before running it.

Loading voting…