Magento Improper Authorization vulnerability
CVE-2025-27188GHSA-rr2g-rrjj-xw86
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist magento/community-edition
- Affected
- < 2.4.4-p13>= 2.4.4, <= 2.4.4>= 2.4.5, <= 2.4.5>= 2.4.6, <= 2.4.6>= 2.4.5-p1, < 2.4.5-p12>= 2.4.6-p1, < 2.4.6-p10>= 2.4.7-p1, < 2.4.7-p5>= 2.4.7, <= 2.4.7>= 2.4.8-beta1, < 2.4.8
- Fixed in
- 2.4.8, 2.4.5-p12, 2.4.7-p5, 2.4.4-p13, 2.4.6-p10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rr2g-rrjj-xw86 lists affected ranges: Packagist magento/community-edition >=0 =2.4.4 =2.4.5 =2.4.6 =2.4.5-p1 =2.4.6-p1 =2.4.7-p1 =2.4.7 =2.4.8-beta1 <2.4.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2025-27188: 0.59% estimated exploitation activity in the next 30 days; percentile 48.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Magento versions 2.4.7-p4, 2.4.6-p9, 2.4.5-p11, 2.4.4-p12, 2.4.8-beta2 and earlier are affected by an Improper Authorization vulnerability that could result in Privilege escalation. An attacker could leverage this vulnerability to bypass security measures and gain unauthorized access. Exploitation of this issue does not require user interaction.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rr2g-rrjj-xw86
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-27188 Advisory: Magento Improper Authorization vulnerability IDs: CVE-2025-27188, GHSA-rr2g-rrjj-xw86 Record: https://patchnext.com/advisories/cve-2025-27188 (revision 1, source checked 26 Oct 2026, 14:33 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: magento/community-edition 2.4.8, 2.4.7-p5, 2.4.6-p10, 2.4.5-p12, 2.4.4-p13. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist magento/community-edition: affected < 2.4.4-p13; >= 2.4.4, <= 2.4.4; >= 2.4.5, <= 2.4.5; >= 2.4.6, <= 2.4.6; >= 2.4.5-p1, < 2.4.5-p12; >= 2.4.6-p1, < 2.4.6-p10; >= 2.4.7-p1, < 2.4.7-p5; >= 2.4.7, <= 2.4.7; >= 2.4.8-beta1, < 2.4.8; fixed in 2.4.8, 2.4.5-p12, 2.4.7-p5, 2.4.4-p13, 2.4.6-p10 ## Suggested inspection (read-only) - Packagist magento/community-edition: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on magento/community-edition. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rr2g-rrjj-xw86 (GitHub-reviewed advisory GHSA-rr2g-rrjj-xw86 lists affected ranges: Packagist magento/community-edition >=0 =2.4.4 =2.4.5 =2.4.6 =2.4.5-p1 =2.4.6-p1 =2.4.7-p1 =2.4.7 =2.4.8-beta1 <2.4.8) Commands are suggestions: review each one before running it.
Loading voting…