Skip to content

← Actionable
High, CVSS 8.4amended

Spotipy's cache file, containing spotify auth token, is created with overly broad permissions

CVE-2025-27154GHSA-pwhh-q4h6-w599

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (spotipy 2.25.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI spotipy

    Affected
    < 2.25.1
    Fixed in
    2.25.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.4 · CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-27154: 0.61% estimated exploitation activity in the next 30 days; percentile 49.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The CacheHandler class creates a cache file to store the auth token here: https://github.com/spotipy-dev/spotipy/blob/master/spotipy/cachehandler.py#L93-L98 The file created has rw-r--r-- (644) permissions by default, when it could be locked down to rw------- (600) permissions. I think 600 is a sensible default. Details This leads to overly broad exposure of the spotify auth token. If this token can be read by an attacker (another user on the machine, or a process running as another user), it can be used to perform administrative actions on the Spotify account, depending on the scope granted to the token. PoC Run an application that uses spotipy with client creation like this: And then check the file permissions on the cache file that was created with: If this issue is combined with another misconfiguration, like having o+r permissions set on your home directory, an attacker will be able to read this file and steal this auth token. Good defense in depth would be to restrict…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-pwhh-q4h6-w599

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-pwhh-q4h6-w599

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-27154

Advisory: Spotipy's cache file, containing spotify auth token, is created with overly broad permissions
IDs: CVE-2025-27154, GHSA-pwhh-q4h6-w599
Record: https://patchnext.com/advisories/cve-2025-27154 (revision 3, source checked 26 Oct 2026, 13:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: spotipy 2.25.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI spotipy: affected < 2.25.1; fixed in 2.25.1

## Suggested inspection (read-only)
- `python -m pip show spotipy`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on spotipy.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pwhh-q4h6-w599 (OSV record GHSA-pwhh-q4h6-w599 lists affected ranges: PyPI spotipy >=0 <2.25.1 (fixed))
- Verified: https://github.com/advisories/GHSA-pwhh-q4h6-w599 (GitHub-reviewed advisory GHSA-pwhh-q4h6-w599 lists affected ranges: PyPI spotipy >=0 <2.25.1)

Commands are suggestions: review each one before running it.

Loading voting…