Skip to content

← Actionable
High, CVSS 7.7amended

axios Requests Vulnerable To Possible SSRF and Credential Leakage via Absolute URL

CVE-2025-27152GHSA-jr5f-v2jv-69x6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (axios 1.8.2, 0.30.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm axios

    Affected
    >= 1.0.0, < 1.8.2< 0.30.0
    Fixed in
    0.30.0, 1.8.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2025-27152: 0.79% estimated exploitation activity in the next 30 days; percentile 56.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A previously reported issue in axios demonstrated that using protocol-relative URLs could lead to SSRF (Server-Side Request Forgery). Reference: axios/axios#6463 A similar problem that occurs when passing absolute URLs rather than protocol-relative URLs to axios has been identified. Even if ⁠baseURL is set, axios sends the request to the specified absolute URL, potentially causing SSRF and credential leakage. This issue impacts both server-side and client-side usage of axios. Details Consider the following code snippet: In this example, the request is sent to http://attacker.test/ instead of the baseURL. As a result, the domain owner of attacker.test would receive the X-API-KEY included in the request headers. It is recommended that: - When baseURL is set, passing an absolute URL such as http://attacker.test/ to get() should not ignore baseURL. - Before sending the HTTP request (after combining the baseURL with the user-provided parameter), axios should verify that the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-jr5f-v2jv-69x6

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-jr5f-v2jv-69x6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-27152

Advisory: axios Requests Vulnerable To Possible SSRF and Credential Leakage via Absolute URL
IDs: CVE-2025-27152, GHSA-jr5f-v2jv-69x6
Record: https://patchnext.com/advisories/cve-2025-27152 (revision 3, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: axios 1.8.2, 0.30.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm axios: affected >= 1.0.0, < 1.8.2; < 0.30.0; fixed in 0.30.0, 1.8.2

## Suggested inspection (read-only)
- `npm ls axios --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on axios.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jr5f-v2jv-69x6 (OSV record GHSA-jr5f-v2jv-69x6 lists affected ranges: npm axios >=1.0.0 =0 <0.30.0 (fixed))
- Verified: https://github.com/advisories/GHSA-jr5f-v2jv-69x6 (GitHub-reviewed advisory GHSA-jr5f-v2jv-69x6 lists affected ranges: npm axios >=1.0.0 =0 <0.30.0)

Commands are suggestions: review each one before running it.

Loading voting…