Skip to content

← Actionable
High, CVSS 7.3amended

Solid Lacks Escaping of HTML in JSX Fragments allows for Cross-Site Scripting (XSS)

CVE-2025-27109GHSA-3qxh-p7jc-5xh6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (solid-js 1.9.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm solid-js

    Affected
    < 1.9.4
    Fixed in
    1.9.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2025-27109: 0.33% estimated exploitation activity in the next 30 days; percentile 25.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Inserts/JSX expressions inside illegal inlined JSX fragments lacked escaping, allowing user input to be rendered as HTML when put directly inside JSX fragments. For instance, ?text=<svg/onload=alert(1) would trigger XSS here.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3qxh-p7jc-5xh6

  2. Revision 1 · created ·

    Published from osv record GHSA-3qxh-p7jc-5xh6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-27109

Advisory: Solid Lacks Escaping of HTML in JSX Fragments allows for Cross-Site Scripting (XSS)
IDs: CVE-2025-27109, GHSA-3qxh-p7jc-5xh6
Record: https://patchnext.com/advisories/cve-2025-27109 (revision 2, source checked 26 Oct 2026, 12:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: solid-js 1.9.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm solid-js: affected < 1.9.4; fixed in 1.9.4

## Suggested inspection (read-only)
- `npm ls solid-js --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on solid-js.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3qxh-p7jc-5xh6 (OSV record GHSA-3qxh-p7jc-5xh6 lists affected ranges: npm solid-js >=0 <1.9.4 (fixed))
- Verified: https://github.com/advisories/GHSA-3qxh-p7jc-5xh6 (GitHub-reviewed advisory GHSA-3qxh-p7jc-5xh6 lists affected ranges: npm solid-js >=0 <1.9.4)

Commands are suggestions: review each one before running it.

Loading voting…