Skip to content

← Actionable
High, CVSS 7.3amended

DOM Expressions has a Cross-Site Scripting (XSS) vulnerability due to improper use of string.replace

CVE-2025-27108GHSA-hw62-58pr-7wc5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (dom-expressions 0.39.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2025-27108: 0.28% estimated exploitation activity in the next 30 days; percentile 20.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

[!NOTE] This advisory was originally emailed to community@solidjs.com by @nsysean. To sum it up, the use of javascript's .replace() opens up to potential XSS vulnerabilities with the special replacement patterns beginning with $. Particularly, when the attributes of Meta tag from solid-meta are user-defined, attackers can utilise the special replacement patterns, either $' or $\ to achieve XSS. The solid-meta package has this issue since it uses useAffect and context providers, which injects the used assets in the html header. "dom-expressions" uses .replace() to insert the assets, which is vulnerable to the special replacement patterns listed above. This effectively means that if the attributes of an asset tag contained user-controlled data, it would be vulnerable to XSS. For instance, there might be meta tags for the open graph protocol in a user profile page, but if attackers set the user query to some payload abusing .replace(), then they could execute arbitrary javascript in the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hw62-58pr-7wc5

  2. Revision 1 · created ·

    Published from osv record GHSA-hw62-58pr-7wc5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-27108

Advisory: DOM Expressions has a Cross-Site Scripting (XSS) vulnerability due to improper use of string.replace
IDs: CVE-2025-27108, GHSA-hw62-58pr-7wc5
Record: https://patchnext.com/advisories/cve-2025-27108 (revision 2, source checked 26 Oct 2026, 12:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dom-expressions 0.39.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm dom-expressions: affected < 0.39.5; fixed in 0.39.5

## Suggested inspection (read-only)
- `npm ls dom-expressions --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dom-expressions.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hw62-58pr-7wc5 (OSV record GHSA-hw62-58pr-7wc5 lists affected ranges: npm dom-expressions >=0 <0.39.5 (fixed))
- Verified: https://github.com/advisories/GHSA-hw62-58pr-7wc5 (GitHub-reviewed advisory GHSA-hw62-58pr-7wc5 lists affected ranges: npm dom-expressions >=0 <0.39.5)

Commands are suggestions: review each one before running it.

Loading voting…