Directus allows updates to non-allowed fields due to overlapping policies
CVE-2025-27089GHSA-99vm-5v2h-h6r6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 11.1.2; @directus/api 23.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm directus
- Affected
- >= 11.0.0, < 11.1.2
- Fixed in
- 11.1.2
npm @directus/api
- Affected
- >= 22.0.0, < 23.1.0
- Fixed in
- 23.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-99vm-5v2h-h6r6 lists affected ranges: npm directus >=11.0.0 =22.0.0 <23.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-99vm-5v2h-h6r6 lists affected ranges: npm directus >=11.0.0 =22.0.0 <23.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2025-27089: 0.24% estimated exploitation activity in the next 30 days; percentile 14.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary If there are two overlapping policies for the update action that allow access to different fields, instead of correctly checking access permissions against the item they apply for the user is allowed to update the superset of fields allowed by any of the policies. E.g. have one policy allowing update access to fielda if the id == 1 and one policy allowing update access to fieldb if the id == 2. The user with both these policies is allowed to update both fielda and fieldb for the items with ids 1 and 2. Details Before v11, if a user was allowed to update an item they were allowed to update the fields that the single permission, that applied to that item, listed. With overlapping permissions this isn't as clear cut anymore and the union of fields might not be the fields the user is allowed to update for that specific item. The solution that this PR introduces is to evaluate the permissions for each field that the user tries to update in the validateItemAccess DB query, instead…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-99vm-5v2h-h6r6
- Revision 1 · created ·
Published from osv record GHSA-99vm-5v2h-h6r6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-27089 Advisory: Directus allows updates to non-allowed fields due to overlapping policies IDs: CVE-2025-27089, GHSA-99vm-5v2h-h6r6 Record: https://patchnext.com/advisories/cve-2025-27089 (revision 2, source checked 26 Oct 2026, 12:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: directus 11.1.2; @directus/api 23.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm directus: affected >= 11.0.0, < 11.1.2; fixed in 11.1.2 - npm @directus/api: affected >= 22.0.0, < 23.1.0; fixed in 23.1.0 ## Suggested inspection (read-only) - `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @directus/api --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on directus, @directus/api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-99vm-5v2h-h6r6 (OSV record GHSA-99vm-5v2h-h6r6 lists affected ranges: npm directus >=11.0.0 =22.0.0 <23.1.0 (fixed)) - Verified: https://github.com/advisories/GHSA-99vm-5v2h-h6r6 (GitHub-reviewed advisory GHSA-99vm-5v2h-h6r6 lists affected ranges: npm directus >=11.0.0 =22.0.0 <23.1.0) Commands are suggestions: review each one before running it.
Loading voting…