Skip to content

← Actionable
Medium, CVSS 5.3amended

Exiv2 allows Use After Free

CVE-2025-26623GHSA-38h4-fx85-qcx7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (exiv2 0.28.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI exiv2

    Affected
    >= 0.28.0, < 0.28.5
    Fixed in
    0.28.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-26623: 0.92% estimated exploitation activity in the next 30 days; percentile 60.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A heap buffer overflow was found in Exiv2 versions v0.28.0 to v0.28.4. Versions prior to v0.28.0, such as v0.27.7, are not affected. Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. The heap overflow is triggered when Exiv2 is used to write metadata into a crafted image file. An attacker could potentially exploit the vulnerability to gain code execution, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when writing the metadata, which is a less frequently used Exiv2 operation than reading the metadata. For example, to trigger the bug in the Exiv2 command-line application, you need to add an extra command-line argument such as fixiso. Patches The bug is fixed in version v0.28.5. References Issue: https://github.com/Exiv2/exiv2/issues/3168 Fix: https://github.com/Exiv2/exiv2/pull/3174 For more information Please see our security policy for…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-38h4-fx85-qcx7

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-38h4-fx85-qcx7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-26623

Advisory: Exiv2 allows Use After Free
IDs: CVE-2025-26623, GHSA-38h4-fx85-qcx7
Record: https://patchnext.com/advisories/cve-2025-26623 (revision 3, source checked 26 Oct 2026, 13:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: exiv2 0.28.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI exiv2: affected >= 0.28.0, < 0.28.5; fixed in 0.28.5

## Suggested inspection (read-only)
- `python -m pip show exiv2`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on exiv2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-38h4-fx85-qcx7 (OSV record GHSA-38h4-fx85-qcx7 lists affected ranges: PyPI exiv2 >=0.28.0 <0.28.5 (fixed))
- Verified: https://github.com/advisories/GHSA-38h4-fx85-qcx7 (GitHub-reviewed advisory GHSA-38h4-fx85-qcx7 lists affected ranges: PyPI exiv2 >=0.28.0 <0.28.5)

Commands are suggestions: review each one before running it.

Loading voting…