Vega Cross-Site Scripting (XSS) via event filter when not using CSP mode expressionInterpeter
CVE-2025-26619GHSA-rcw3-wmx7-cphr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vega 5.31.0; vega-functions 5.16.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm vega
- Affected
- < 5.31.0
- Fixed in
- 5.31.0
npm vega-functions
- Affected
- < 5.16.0
- Fixed in
- 5.16.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rcw3-wmx7-cphr lists affected ranges: npm vega >=0 =0 <5.16.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rcw3-wmx7-cphr lists affected ranges: npm vega >=0 =0 <5.16.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2025-26619: 0.35% estimated exploitation activity in the next 30 days; percentile 29.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact In vega 5.30.0 and lower, vega-functions 5.15.0 and lower , it was possible to call JavaScript functions from the Vega expression language that were not meant to be supported. Patches Patched in vega 5.31.0 / vega-functions 5.16.0 Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? - Run vega without vega.expressionInterpreter. This mode is not the default as it is slower. - Using the interpreter described in CSP safe mode (Content Security Policy) prevents arbitrary Javascript from running, so users of this mode are not affected by this vulnerability. References - Reported to Vega-Lite by @kprevas Nov 8 2024 in https://github.com/vega/vega-lite/issues/9469 & https://github.com/vega/vega/issues/3984 Reproduction of the error in Vega by @mattijn
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-rcw3-wmx7-cphr
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-rcw3-wmx7-cphr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-26619 Advisory: Vega Cross-Site Scripting (XSS) via event filter when not using CSP mode expressionInterpeter IDs: CVE-2025-26619, GHSA-rcw3-wmx7-cphr Record: https://patchnext.com/advisories/cve-2025-26619 (revision 3, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vega 5.31.0; vega-functions 5.16.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm vega: affected < 5.31.0; fixed in 5.31.0 - npm vega-functions: affected < 5.16.0; fixed in 5.16.0 ## Suggested inspection (read-only) - `npm ls vega --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls vega-functions --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vega, vega-functions. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rcw3-wmx7-cphr (OSV record GHSA-rcw3-wmx7-cphr lists affected ranges: npm vega >=0 =0 <5.16.0 (fixed)) - Verified: https://github.com/advisories/GHSA-rcw3-wmx7-cphr (GitHub-reviewed advisory GHSA-rcw3-wmx7-cphr lists affected ranges: npm vega >=0 =0 <5.16.0) Commands are suggestions: review each one before running it.
Loading voting…