Moodle allows teachers to evade trusttext config when restoring glossary entries
CVE-2025-26532GHSA-cw24-f6fq-7j9v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 4.5.2, 4.4.6, 4.3.10, 4.1.16), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist moodle/moodle
- Affected
- >= 4.5.0-beta, < 4.5.2>= 4.4.0-beta, < 4.4.6>= 4.3.0-beta, < 4.3.10< 4.1.16
- Fixed in
- 4.1.16, 4.3.10, 4.5.2, 4.4.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cw24-f6fq-7j9v lists affected ranges: Packagist moodle/moodle >=4.5.0-beta =4.4.0-beta =4.3.0-beta =0 <4.1.16
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.1 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2025-26532: 0.27% estimated exploitation activity in the next 30 days; percentile 18.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Additional checks were required to ensure trusttext is applied (when enabled) to glossary entries being restored.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-cw24-f6fq-7j9v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-26532 Advisory: Moodle allows teachers to evade trusttext config when restoring glossary entries IDs: CVE-2025-26532, GHSA-cw24-f6fq-7j9v Record: https://patchnext.com/advisories/cve-2025-26532 (revision 1, source checked 26 Oct 2026, 14:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 4.5.2, 4.4.6, 4.3.10, 4.1.16. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist moodle/moodle: affected >= 4.5.0-beta, < 4.5.2; >= 4.4.0-beta, < 4.4.6; >= 4.3.0-beta, < 4.3.10; < 4.1.16; fixed in 4.1.16, 4.3.10, 4.5.2, 4.4.6 ## Suggested inspection (read-only) - Packagist moodle/moodle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on moodle/moodle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cw24-f6fq-7j9v (GitHub-reviewed advisory GHSA-cw24-f6fq-7j9v lists affected ranges: Packagist moodle/moodle >=4.5.0-beta =4.4.0-beta =4.3.0-beta =0 <4.1.16) Commands are suggestions: review each one before running it.
Loading voting…