Skip to content

← Actionable
Low, CVSS 3.1

Moodle has an IDOR in badges allows disabling of arbitrary badges

CVE-2025-26531GHSA-g88w-v4cq-qgcp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 4.5.2, 4.4.6, 4.3.10, 4.1.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist moodle/moodle

    Affected
    >= 4.5.0-beta, < 4.5.2>= 4.4.0-beta, < 4.4.6>= 4.3.0-beta, < 4.3.10< 4.1.16
    Fixed in
    4.1.16, 4.3.10, 4.5.2, 4.4.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N
EPSS
  • CVE-2025-26531: 0.30% estimated exploitation activity in the next 30 days; percentile 22.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Insufficient capability checks made it possible to disable badges a user does not have permission to access.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-g88w-v4cq-qgcp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-26531

Advisory: Moodle has an IDOR in badges allows disabling of arbitrary badges
IDs: CVE-2025-26531, GHSA-g88w-v4cq-qgcp
Record: https://patchnext.com/advisories/cve-2025-26531 (revision 1, source checked 26 Oct 2026, 14:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 4.5.2, 4.4.6, 4.3.10, 4.1.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist moodle/moodle: affected >= 4.5.0-beta, < 4.5.2; >= 4.4.0-beta, < 4.4.6; >= 4.3.0-beta, < 4.3.10; < 4.1.16; fixed in 4.1.16, 4.3.10, 4.5.2, 4.4.6

## Suggested inspection (read-only)
- Packagist moodle/moodle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on moodle/moodle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-g88w-v4cq-qgcp (GitHub-reviewed advisory GHSA-g88w-v4cq-qgcp lists affected ranges: Packagist moodle/moodle >=4.5.0-beta =4.4.0-beta =4.3.0-beta =0 <4.1.16)

Commands are suggestions: review each one before running it.

Loading voting…