Skip to content

← Actionable
High, CVSS 8.3

Moodle has a stored XSS risk in admin live log

CVE-2025-26529GHSA-wr88-x8cm-7cgq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 4.5.2, 4.4.6, 4.3.10, 4.1.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist moodle/moodle

    Affected
    >= 4.5.0-beta, < 4.5.2>= 4.4.0-beta, < 4.4.6>= 4.3.0-beta, < 4.3.10< 4.1.16
    Fixed in
    4.1.16, 4.3.10, 4.5.2, 4.4.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.3 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2025-26529: 0.52% estimated exploitation activity in the next 30 days; percentile 44.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description information displayed in the site administration live log required additional sanitizing to prevent a stored XSS risk.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wr88-x8cm-7cgq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-26529

Advisory: Moodle has a stored XSS risk in admin live log
IDs: CVE-2025-26529, GHSA-wr88-x8cm-7cgq
Record: https://patchnext.com/advisories/cve-2025-26529 (revision 1, source checked 26 Oct 2026, 14:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 4.5.2, 4.4.6, 4.3.10, 4.1.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist moodle/moodle: affected >= 4.5.0-beta, < 4.5.2; >= 4.4.0-beta, < 4.4.6; >= 4.3.0-beta, < 4.3.10; < 4.1.16; fixed in 4.1.16, 4.3.10, 4.5.2, 4.4.6

## Suggested inspection (read-only)
- Packagist moodle/moodle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on moodle/moodle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wr88-x8cm-7cgq (GitHub-reviewed advisory GHSA-wr88-x8cm-7cgq lists affected ranges: Packagist moodle/moodle >=4.5.0-beta =4.4.0-beta =4.3.0-beta =0 <4.1.16)

Commands are suggestions: review each one before running it.

Loading voting…