Moodle's non-searchable tags can still be discovered on the tag search page and in the tags block
CVE-2025-26527GHSA-5r85-6h7f-rg3r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 4.5.2, 4.4.6, 4.3.10, 4.1.16), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist moodle/moodle
- Affected
- >= 4.5.0-beta, < 4.5.2>= 4.4.0-beta, < 4.4.6>= 4.3.0-beta, < 4.3.10< 4.1.16
- Fixed in
- 4.1.16, 4.3.10, 4.5.2, 4.4.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5r85-6h7f-rg3r lists affected ranges: Packagist moodle/moodle >=4.5.0-beta =4.4.0-beta =4.3.0-beta =0 <4.1.16
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2025-26527: 0.37% estimated exploitation activity in the next 30 days; percentile 30.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Tags not expected to be visible to a user could still be discovered by them via the tag search page or in the tags block.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5r85-6h7f-rg3r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-26527 Advisory: Moodle's non-searchable tags can still be discovered on the tag search page and in the tags block IDs: CVE-2025-26527, GHSA-5r85-6h7f-rg3r Record: https://patchnext.com/advisories/cve-2025-26527 (revision 1, source checked 26 Oct 2026, 14:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 4.5.2, 4.4.6, 4.3.10, 4.1.16. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist moodle/moodle: affected >= 4.5.0-beta, < 4.5.2; >= 4.4.0-beta, < 4.4.6; >= 4.3.0-beta, < 4.3.10; < 4.1.16; fixed in 4.1.16, 4.3.10, 4.5.2, 4.4.6 ## Suggested inspection (read-only) - Packagist moodle/moodle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on moodle/moodle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5r85-6h7f-rg3r (GitHub-reviewed advisory GHSA-5r85-6h7f-rg3r lists affected ranges: Packagist moodle/moodle >=4.5.0-beta =4.4.0-beta =4.3.0-beta =0 <4.1.16) Commands are suggestions: review each one before running it.
Loading voting…