Skip to content

← Actionable
High, CVSS 8.8

Instaclustr Cassandra-Lucene-Index allows bypass of Cassandra RBAC

CVE-2025-26511GHSA-mrqp-q7vx-v2cx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.instaclustr:cassandra-lucene-index-plugin 4.1.8-1.0.1, 4.0.17-1.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-mrqp-q7vx-v2cx lists affected ranges: Maven com.instaclustr:cassandra-lucene-index-plugin >=4.0-rc1-1.0.0 =4.1.0-1.0.0 <4.1.8-1.0.1

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2025-26511: 0.57% estimated exploitation activity in the next 30 days; percentile 47.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary / Details Systems running the Instaclustr fork of Stratio's Cassandra-Lucene-Index plugin versions 4.0-rc1-1.0.0 through 4.0.16-1.0.0 and 4.1.0-1.0.0 through 4.1.8-1.0.0, installed into Apache Cassandra version 4.x, are susceptible to a vulnerability which when successfully exploited could allow authenticated Cassandra users to remotely bypass RBAC to access data and and escalate their privileges. Affected Versions - Cassandra-Lucene-Index plugin versions 4.0-rc1-1.0.0 through 4.0.16-1.0.0 - versions 4.1.0-1.0.0 through 4.1.8-1.0.0 when installed into Apache Cassandra version 4.x. Required Configuration for Exploit These are the conditions required to enable exploit: 1. Cassandra 4.x 2. Vulnerable version of the Cassandra-Lucene-Index plugin configured for use 3. Data added to tables 4. Lucene index created 5. Cassandra flush has run Mitigation/Prevention Mitigation requires dropping all Lucene indexes and stopping use of the plugin. Exploit will be possible any time the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-mrqp-q7vx-v2cx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-26511

Advisory: Instaclustr Cassandra-Lucene-Index allows bypass of Cassandra RBAC
IDs: CVE-2025-26511, GHSA-mrqp-q7vx-v2cx
Record: https://patchnext.com/advisories/cve-2025-26511 (revision 1, source checked 26 Oct 2026, 16:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: com.instaclustr:cassandra-lucene-index-plugin 4.1.8-1.0.1, 4.0.17-1.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.instaclustr:cassandra-lucene-index-plugin: affected >= 4.0-rc1-1.0.0, < 4.0.17-1.0.0; >= 4.1.0-1.0.0, < 4.1.8-1.0.1; fixed in 4.0.17-1.0.0, 4.1.8-1.0.1

## Suggested inspection (read-only)
- Maven com.instaclustr:cassandra-lucene-index-plugin: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.instaclustr:cassandra-lucene-index-plugin.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mrqp-q7vx-v2cx (GitHub-reviewed advisory GHSA-mrqp-q7vx-v2cx lists affected ranges: Maven com.instaclustr:cassandra-lucene-index-plugin >=4.0-rc1-1.0.0 =4.1.0-1.0.0 <4.1.8-1.0.1)

Commands are suggestions: review each one before running it.

Loading voting…