Laravel Starter Cross Site Scripting (XSS)
CVE-2025-26159GHSA-fpx3-h2pc-88vf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nasirkhan/laravel-starter 11.11.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist nasirkhan/laravel-starter
- Affected
- < 11.11.0
- Fixed in
- 11.11.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fpx3-h2pc-88vf lists affected ranges: Packagist nasirkhan/laravel-starter >=0 <11.11.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2025-26159: 0.31% estimated exploitation activity in the next 30 days; percentile 24.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Laravel Starter 11.11.0 is vulnerable to Cross Site Scripting (XSS) in the tags feature. Any user with the ability of create or modify tags can inject malicious JavaScript code in the name field.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fpx3-h2pc-88vf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-26159 Advisory: Laravel Starter Cross Site Scripting (XSS) IDs: CVE-2025-26159, GHSA-fpx3-h2pc-88vf Record: https://patchnext.com/advisories/cve-2025-26159 (revision 1, source checked 26 Oct 2026, 14:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nasirkhan/laravel-starter 11.11.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist nasirkhan/laravel-starter: affected < 11.11.0; fixed in 11.11.0 ## Suggested inspection (read-only) - Packagist nasirkhan/laravel-starter: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nasirkhan/laravel-starter. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fpx3-h2pc-88vf (GitHub-reviewed advisory GHSA-fpx3-h2pc-88vf lists affected ranges: Packagist nasirkhan/laravel-starter >=0 <11.11.0) Commands are suggestions: review each one before running it.
Loading voting…